I have this problem which involves writing MSMQ messages from machine A (Windows 7) to machine B (Windows Server 2008) which are in the same network. This problem only occurs when the message is sent from a local account; it works great when sending the message from my domain user account and the local system user (LocalService).

Info and troubleshooting so far:

The dead-letter queue at machine A is filled with messages labeled "Access denied".

The receiving queues on machine B has all permissions granted to the "Everyone" group. This also goes for the overlying security settings of the "Message Queuing" feature. I have also tried granting all permissions to the computer name of machine A.

Events are showing up under machine A's Event Viewer/Applications and Services/Microsoft/Windows/MSMQ/End2End, labeled as "Message came over network". There are, however, no relevant messages shown under Event Viewer/Windows Logs/Application or Security.

The messages sent from machine A and the receiving queues on machine B both have the transactional setting enabled.

I have tried turning off the Windows firewall with no result.

Question: I suspect that this has something to do with machine B not recognizing the local account used on machine A. Is there in some way possible to grant this account the right permission on machine B so that machine A can write to machine B's queue?


Turns out I needed to add the permission "Send Message" for the user group "ANONYMOUS LOGON" in the Security settings of the MSMQ queue.

These pages led me to the answer:

Access To Message Queue System Denied Windows 7 Reading Windows 2003 - Windows 2008

MSMQ 3.0 too secure for you?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.