I've deployed BES against Exchange 2003, but know very little about it. I now have a problem that is testing the limits of my knowledge.

One user recently stopped getting messages on the phone. They appear in the mailbox and seem to be ok in Outlook. The user can send mail correctly. SMS works. I can send PIN messages to the phone from the BES console. The emails never synchronize. I've restarted the server just to verify it's not gone insane. The user actually was expecting a new phone, so we activated it when it came in just in case the phone itself was malfunctioning. No Luck.

The log files are basically undecipherable. I don't see anything obviously wrong, though.

How do you go about troubleshooting something like this?


Have you tried removing the users license and resetting it?

You can also check the permissions on the users mailbox and makesure that the BES account has enough rights to the users mailbox.

Also ensure that the inbox and other folders are setup for sync (this can be checked on the server, or the users Desktop Manager on the PC).


Check and make sure the user's inbox is still enabled for redirection. Right click the user and select choose folders for redirection from the blackberry server manager.

If it is turned off, you can re-enable it, Then check this link for information and see if this is what happened.

Also check and make sure the user doesn't have the messages filtered, if they were playing with that trying to adjust the filters for messages going to the BB they might have accidently filtered everything.


Finally pinned it down. Using the 'mail flow' tool in the BRK, I see all messages going to this user as 'filtered'. I investigated the filter rules on that user in the BES manager and found none.

Just for kicks, I toggled the setting 'Forward messages to Blackberry device' from True to False to True and now it works perfectly.

Very enterprise-y.

  • LOL, "enterprise-y", sounds about right. I find the old battery pull fixes 90% of BlackBerry issues. – ITGuy24 Aug 14 '09 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.