10

I have Server 2012 with one storage pool and one virtual disk. The virtual disk uses layout parity and thin provisioning. It contained 4 physical disks. One of the physical disks failed. It was pulled and larger replacement disk was added.

The server manager now lists the failed drive as "Retired". Every attempt to remove the disk results in:

Error removing physical disk: There was an error removing {179f49b7-7657-11e2-93ea-806e6f6e6963} (fileserver). One of the physical disks specified could not be removed because it is still in use.

If I check the properties of the virtual disk, it states under health: "Physical disks in use", and lists the retired drive as "Lost Communication".

The physical drives have lots of free space, and the new drive has been added to the storage pool (but not the virtual disk). The "repair virtual disk" option is grayed out.

It seems I cannot attach the virtual disk until I remove the retired drive.

How can a disk that's sitting unplugged in another room be "in use"? How do I remove the retired drive?

  • you can't repair it unless it is communicating so that makes sense. I haven't tried it, but can you uninstall the drive from device manager? (or is it gone from there too?) This might be something that is stuck in the registry. Does it show up in "diskpart"? – MikeAWood Jul 9 '13 at 23:50
  • This sounds to me like something somewhere is 'stuck'. I know it's a silly question, but have you tried just restarting the affected server? This would be my very first action before trying anything else. – tfrederick74656 Oct 1 '14 at 22:54
  • 1
    Can you try: Set-PhysicalDisk -FriendlyName 'whatevername' -Usage Retired then Remove-PhysicalDisk -FriendlyName 'whatevername' from powershell? – Iulian Dec 30 '14 at 23:13
  • Do you have a screenshot of the disk manager you can share? – Citizen Jan 24 '15 at 2:24
2
+50

I believe I've seen this once with a customer, and it seemed to just be a Storage Spaces bug. Rather than going to Microsoft for support on the issue though, they opted to just backup/restore the data and recreate the storage space and virtual disk.

This is not normal behavior though - replacing the physical disk should allow you to "replace" and "repair" with no issue. I'd recommend contacting Microsoft to report the bug / erroneous behavior if that's an option for you, otherwise you may be stuck recreating and restoring.

Still, as others have mentioned, you should definitely try a reboot. I'd also recommend testing with an additional replacement disk. Iulian's PowerShell command suggestions are worth a try too, but those did not work for me when running into this issue.

  • I too came to the constitution that it was a bug and that recovery was doomed. In the end I purchased larger drives and switched to mirroring (better recovery options than with thin provisioning) – mbursill Feb 9 '15 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.