I am trying to install Debian Squeeze 64 bit OS in the "Intel® Server Board S2600CP" server. But while installing the OS , hard disk is not detecting to do the partition. When we search in internet , We found that red hat has been using megasr module to detect raid controller. This raid controller has been provided by intel. We try to get equivalent driver for our debian Squeeze OS.

I have tried following thing to get rid of this problem. But no solution yet.

  1. I have converted the red hat rpm package into .deb package which is compatible to debian. and I have installed that debian package successfully. But Hard disk is not detected and I could not found any driver called megasr when I put lsmod. When I try modprobe mesasr command. It also said that megasr module not found.

  2. Then we took the kernel object megesr driver. which was compiled for red hat. Named megasr.ko .We try install above .ko file by using below steps

    $ insmod megasr.ko But it thrown error as follows insmod: error inserting megasr.ko: -1 Invalid module format.

    we understand that this error could have been thrown , since we are trying to install red hat kernel object.

  3. Then we thought , latest kernel of linux would be having this driver build in. So, we downloaded the latest stable version of linux kernel 3.9.6 . We build this kernel and booted the machine with this kernel. Still we could not make hard disk to detect and we are not able to find the driver in the lsmod module listing.

  4. Some where we read that for LSI megaraid we have driver called mptsas. We have installed this module successfully. Even then hard disc was not detected.

If anyone come across this issue , please give us the idea to overcome.

Please ascertain this issue. Whether it is possible to make hard disk to be detected in debian. Or any work around need to be done to achieve this process. Please guide in this regard.


  • 2
    Have you not considered using a supported operating system instead of struggling, if you carry on this way you'll spend all your time dealing with problems. Could you not just use Centos? – Chopper3 Jun 22 '13 at 12:13
  • I have approved the edit assuming that @Pavunkumar and muruga are the same person or otherwise related. – Sven Jun 22 '13 at 12:16
  • 2
    Beside just using CentOS, have you tried a newer Debian? v7 "Wheezy" is out now and it might include the driver you need. – Sven Jun 22 '13 at 12:18
  • 1
    If it is important to you to use Debian Squeeze then it might be a good idea to install a distro with the driver on bare metal and run Debian Squeeze in a VM. – Hauke Laging Jun 22 '13 at 14:29

Try the answer suggested in this bug report:

Setting linux kernel boot parameter pci=conf1 allows my Intel RAID Controller-RMS25PB080 (LSI 2208/Fusion based) to be detected

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.