After spending almost 3 days on this issue without any idea how to solve it or finding similar problems on serverfault and other communities, I guess I have to open a question. Here's the problem:

We work in a pure Mac environment, however for some applications and machines we need a few Windows PCs. Up until now they have all used Windows XP as OS, however we recently built a fresh Windows client and decided to go ahead with Windows 8.

Data for those 3 to 4 Windows boxes is served from a Mac Mini running Mountain Lion Server. The share in questions is an external RAID-System attached to the Mac Mini / Server. We will call this one "ShareX".

  • On our Mac clients everything is and has been fine - naturally, AFP is used for file sharing on these clients though.

  • On our Windows XP boxes and virtual machines everything is fine as well

  • On the new Windows 8 box \\server\ShareX is not reachable:

    • the progress bar in the location field on this client will progress into eternity when trying to access this share, until explorer.exe becomes unresponsive
    • meanwhile \\server\ShareA, ShareB or ShareC are accessible without problems
    • even subfolder of ShareX are working fine, e.g. \\server\ShareX\SubfolderY - so only the root of the share seems to be affected
    • for testing I also installed Windows 8 in a virtual machine -> exactly the same issues
    • we have another Windows 7 based controller PC, which behaves as flawless as the XP systems - can access everything
  • oddly enough in about 1 out of 30 times I can access the problematic share, however if I open another subfolder and try to go back to the root of the share explorer.exe is unresponsive again.

This is what I tried:

  • killed and restarted the smb sharing service
  • restarted the server
  • deleted and recreated the share
  • just for testing also served the share via FTP, which Windows 8 could access just fine. So it's only related to SMB, not the data itself it seems.
  • checked the external raid system for errors. Everything's ok according to Apple's Disk Utility

At this point I'm really out of ideas. Any help is appreciated.

Has anyone come across a similar problem?



Well, nevermind...I went ahead and replaced Apple's Samba implementation with SMBup which fetches the current official Samba release and deactivates Apple's SMB service.

Everything worked instantly and my shares are now accessible from XP to Windows 8 on all machines.

In case anyone else experiences problems with the SMB service in OSX, this could be an alternative.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.