I've installed Windows 2003 x64 R2 SP2 under Hyper-V (the Windows Pro 8 edition).

I have a NIC configured but I can't move any traffic on it. In particular I can't send or receive Pings.


There is a second VM running Ubuntu under the Windows 8 host which is able to send and receive pings from the host O/S .

When I try to ping from Windows 2003 guest to Windows 8 host I get 'Request Timed Out'.

When I try to ping from Windows 8 host to Windows 2003 guest I get 'Reply from Destination Host Unreachable'.

There's no problem pinging from the Ubuntu guest to the Windows 8 host and no problem pinging from the Windows 8 host to the Unbuntu guest.


Integration services are installed on Windows 2003.

The windows 2003 needs a static IP address of

The Windows 2003 ipconfig output looks like this :

enter image description here

While the host o/s ipconfig output looks like this : enter image description here

Event Logs

The only things I can see in the event logs which is (a) looks signifcant and (b) is not related to the lack of networking is this :

enter image description here

I'm not sure if that's significant or not.

Hyper-V and NICs

When the Windows 2003 guest was first booted it had no NIC; I subsequently added a 'Legacy Network Connector' which I couldn't get Windows 2003 to recognise; I subsequently removed that and added a 'Standard Network Connector' and at least on the surface this works ... only it doesn't.

'Virtual Network Type' is external.

Although I've only mentioned ping there's no other evidence of network activity.

'Allow incoming echo request' is enabled on the Windows 2003 guest.


What else should I look at or do to resolve this problem ?

EDIT 1: I should have said that I turned off the firewall on the W2003 server for a while and retested the pings; same result.

EDIT 2: Just to be quite clear the following setting is present on the Windows 2003 guest (and has been throughout my testing):

enter image description here

EDIT 3: I've just noticed something that may give a clue to the problem. When I do a 'net statistics' command on the guest W2003 o/s I get the following response which seems to suggest that there is network traffic coming and going from the machine ?

enter image description here


Go to Control Panel, and double-click on Windows Firewall. Under the ICMP section, click on the Settings... button and you will see a list of checkboxes. Check the Allow incoming echo request checkbox. This will enable your Windows Server 2003 installation to return a respond when the server is pinged.

| improve this answer | |
  • Thank you for your reply, I appreciate it. Unfortunately I had already checked that box and still the situation is as it is. If you have any other suggestions that would be great ! – glaucon Jun 30 '13 at 10:44

Just for the sake of posterity I should answer my own question as I've now got it working. In summary I 'took out' the network adapter; booted without it; and then put it back in and all was well.

Here's the more detailed version.

I stopped the client VM Windows 2003 machine; went into Hyper-V manager on the host W8 Pro machine and selected the client VM Windows 2003 machine; selected 'Settings' in the Action panel; selected 'Network Adapter' in the Navigation Panel and then pressed the 'Remove' button.

I then rebooted the client VM Windows 2003 machine with no nic. I'm not sure this was significant but I'd read something which suggested it might be. Once the client VM Windows 2003 machine was up I shut it down again immediately.

One the client VM Windows 2003 machine had stopped; went into Hyper-V manager and selected the client VM Windows 2003 machine; selected 'Settings' in the Action panel; selected 'Add Hardware' in the Navigation panel; and selected 'Network Adapter' from the list of available hardware.

I then rebooted the client VM Windows 2003 machine and all was well !

Thanks again to those who made suggestions.

| improve this answer | |

The error message that you're getting says it all, Windows 2003 is unable to bind the TCP/IP module to the network card. Based on information from Microsoft, I would start by suggesting to install the the following:

  • Service Pack 2 for the Windows 2003 Server.
  • The Windows Integration Services for Hyper V clients (this should have drivers for the network card).

I believe that the second task should solve your problem, if not, keep us posted :)

| improve this answer | |
  • Thanks for your reply. I do have SP2 installed and I do have 'Windows Integration Services' installed. It's a good point you make though because I didn't originally have the 'Integration Services' installed and that was very confusing. I have wondered if I should de-install all NIC's after having installed 'Integration Services' and then re-install ? I've tried both 'Legacy Network Adapter' (which some sources suggest you need for W2003) and 'Network Adapter' (which some sources suggest is right for W2003 x64) . Any ideas on this ? – glaucon Jun 30 '13 at 22:41
  • This is very weird, If you have SP2 and the integration services installed, it should work fine. I believe that you might have a problem with the TCP/IP stack itself, you can force to a refresh for it using this link: support.microsoft.com/kb/317518, let me know if this works. – Noor Khaldi Jul 2 '13 at 8:15
  • thank you for your suggestion. I did try restarting the tcp/ip stack and unfortunately that didn't help (although as you can see from my answer of today I did manage to get it working eventually). – glaucon Jul 7 '13 at 6:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.