2

I've set authentication level:i:0 in the RDP file, but when I connect to this computer with mstsc it asks me if I want to connect to this computer, so the parameter is ignored by the mstsc. How to fix it?

enter image description here

  • Got a screenshot? it could be prompting b/c the publisher couldn't be verified, setting the authentication level won't help that. – MDMoore313 Jun 29 '13 at 19:13
  • @MDMoore313 I've uploaded the screenshot. – arts777 Jun 29 '13 at 19:17
2

Just as I suspected, it's a publisher warning. Auth level won't help that, but there's a couple of things you can do.

1) Sign the RDP shortcut. This involves digitally signing the shortcut with a certificate that is trusted in your environment. This was a bit too involved for me to do in my environment, but there's enought info online for it to be done. There's an exe that comes with the server OSes that's called rdpsign, and you use that to sign the rdp file.

2)Checking that checkbox will insert a reg key onto the computer to let it know that rdp connections to that computer are okay, so it doesn't prompt again. You could add the reg key to your clients via group policy, or whatever you prefer. I forget where it writes, this question addresses it partially, but I have a feeling it writes to other reg keys also, b/c there is a key that stores the fqdn. It should be trivial to find with procmon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.