My server was terminated abnormally because power was turned off. After start server I can't to run Apache.

$ /etc/init.d/httpd start
Starting httpd:                                            [FAILED]

Apache log file:

[notice] suexec mechanism enabled (wrapper /usr/sbin/suexec)

$ ll /usr/sbin/suexec
-rws--x--x 1 root apache 11544 Nov 12 2008 /usr/sbin/suexec

I was tryed to run suexec:

suexec policy violation: see suexec log for more details

SUEXEC log file:

too few arguments

Сan anyone suggest a solution to this problem?

UPD:

$ suexec -V
-D AP_DOC_ROOT="/var/www"
-D AP_GID_MIN=100
-D AP_HTTPD_USER="apache"
-D AP_AP_LOG_EXEC="/var/log/httpd/suexec.log"
-D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
-D AP_UID_MIN=500
-D AP_USERDIR_SUFFIX="public_html"

OS: Redhat Linux 2.6.18-128el15

Apache 2.2.3

  • What about suexec -V? – Nathan C Jul 2 '13 at 11:32
  • What changed? Do you always reboot your server after software upgrades/reconfigurations to make sure they still boot? What OS and Distro is this? What version of Apache? – Chris S Jul 2 '13 at 13:00
  • No changes was @ChrisS – alexBl Jul 2 '13 at 13:36
up vote 0 down vote accepted

I fixed it by removing ssl.conf from an included config files to httpd.conf

In my case, ssl.conf was misconfigured. So i renamed ssl.conf to ssl.conf.old and create a default ssl.conf file again and copied the default contents.

Default contents can be copied from https://serverfault.com/a/474467/274486

or http://www.techrappers.com/post/13117/apache-webserver-fails-start-suexec-mechanism-enabled

After that i tried to restart Apache and it worked like a charm!

This post put me to right direction:

https://support.plesk.com/hc/en-us/articles/115000065589-Apache-webserver-fails-to-start-suEXEC-mechanism-enabled

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.