I have a Draytek Vigor 2830n. It's kicking out a LAN. It performs load-balancing across dual-WAN ports, although I've turned off the second WAN to simplify testing. There are many hosts on the LAN. All IPs are allocated through DHCP, most freely allocated from the pool, but one or two are bound to NIC MAC addresses.

All hosts can access the Internet, save one. That host ( or 'dot100' for short) gets allocated an IP address (and the right gateway address, DNS server addresses, subnet etc.) dot100 can ping itself. It can ping the gateway, and access the latter's web interface via port 80. It's responsive and loss-free (sustained ping over a couple of minutes reports no data loss). Yet, for some reason that evades me, dot100 can't ping an external IP address or domain name. I suspect it's never been able to, because it was getting some Internet access from a second adaptor (different subnet), but that's now been turned off, which exposed the problem.

In dot100, I've tried:

  • two operating systems (Windows 8 and Knoppix), to rule out anti-virus programs etc.
  • two physical adaptors
  • two cables, on each adaptor
  • two IPs (e.g. .100 and .103 assigned by Mac and .26 from the pool)
  • both dynamic and assigned (MAC-bound) DHCP-allocated IPs

but none of this experiments yielded any variation in the result. dot100 is a crucial host. It's a file server for the network, so I need it to be reliably allocated a consistent IP. Can anyone offer a potential solution or a way forward with the analysis please?

My guess

My analysis so far leads me to believe it's a router issue. I've checked the web interface very carefully. There are no filters setup in Firewall -> General Setup or Filter Setup. I suspect it's a corrupted internal routing table, but the web UI shows this as the Routing table:

Key: C - connected, S - static, R - RIP, * - default, ~ - private
*            via 62.XX.XX.X        WAN1
*         62.XX.XX.X/  via 62.XX.XX.X        WAN1
S      82.YY.YYY.YYY/  via 82.YY.YYY.YYY     WAN1
C    directly connected    WAN2
C~    directly connected    LAN2
  • 1
    have you checked to see if the router has any firewall or access-list configured to block Dot100? That would be my first guess. – emynd Jul 3 '13 at 15:14
  • ok so when you say you used "Two ips" does that mean the same server with an address other then .100? – tony roth Jul 3 '13 at 16:36
  • also was this working then quit or its never worked, if it was working then what changes have been made to break it? – tony roth Jul 3 '13 at 16:37
  • Have you tried a trace route to see where exactly the traffic is getting stuck? – john Jul 3 '13 at 17:19
  • Yes, traceroute shows the traffic getting to the router, but no further. – user1444233 Jul 4 '13 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.