1

I just installed Ajenti to my server, that runs nginx. I have a domain already setted up and everything works, except Ajenti.

I added this config to nginx, to reach Ajenti:

server{
        listen 80;
        server_name ajenti.XY.dk;

        access_log /XY/_log/ajenti.access.log;
        error_log /XY/_log/ajenti.error.log;

        add_header Strict-Transport-Security max-age=2592000;
        location /* {
                rewrite /* http://127.0.0.1:8000 permanent;
        }
}

And yes, I added a symlink to sites-enabled for it. But I can not reach it from outside. I tried Linx on the server and it opened Ajenti, so it is running.

What should I change in my config?

0

Use proxy_pass instead of rewrite.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.