1

The DHCP server on our SBS 2003 server shuts itself down automatically after a couple of hours of having a Hamachi gateway running on the same LAN.

Event ID 1053

Event Viewer

The server incorrectly assumes that Hamachi might start assigning DHCPs to other clients on the LAN.

While the Hamachi gateway client does indeed have a DHCP server, it only assigns IPs to computers making inbound VPN connections- not to PCs on the LAN.

Does anyone know of a way to override this behaviour on SBS 2003? Perhaps a registry hack?

I know the server has good intentions when it disables its DHCP server in this situation... however, in avoiding a non-existent problem, it is actually creating a real problem.

  • what do you mean non overlapping IP Scopes. DHCP is a broadcast protocol and happens before you even get to IP. With both answering. Which ever one answers first will provide the IP to the requesting computer. The correct answer is to disable the DHCP server on the hamachi box from listening on that interface. – Doon Jul 2 '13 at 19:55
  • I was thinking about that- I guess the fact they are both on the same subnet is all it takes for there to be a conflict. – Austin ''Danger'' Powers Jul 2 '13 at 20:15
  • There's no way to disable that function AFAIK but just to clarify, it's not shutting down because it detects a "rogue" DHCP server, it's shutting down because it detects another DHCP server, period. Whether that other DHCP server is a rogue DHCP server or, as in your case, a perfectly legitimate DHCP server. Not everything needs to imply a nefarious intent. – joeqwerty Jul 2 '13 at 21:35
  • I'm fascinated that this "feature" is apparently specific to Small Business Server. Microsoft make assumptions about the environments different OS's will be installed in. Crikey! – Austin ''Danger'' Powers Jul 2 '13 at 23:51
  • What kind of switch are you using? You can use DHCP snooping to squash DHCP services from non-authorized sources. – SpacemanSpiff Jul 3 '13 at 0:00
6

IF you really want to you can disable rogue DHCP server detection by setting the REG_DWORD value DisableRogueDetection to 1 under HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\DHCPServer\Parameters.

As an aside: It kinda sounds like you installed the Hamachi adapter directly on the Windows SBS 2003 computer. If that's the case then you're probably going to have issues with a multi-homed domain controller to start worrying about.

  • This is exactly what I've been trying to find. Thanks – Austin ''Danger'' Powers Jul 3 '13 at 20:41
  • The Hamachi gateway isn't installed on the server itself- just a separate XP Pro system on the same LAN. (I've heard about the problems installing it on an SBS server can cause, so did it this way to avoid any issues.) I've tried the registry key and already I can see it totally solved our problem- I can start DHCP again without it instantly switching itself back off. Great to see our DHCP server and Hamachi gateway finally happily co-existing on the LAN. – Austin ''Danger'' Powers Jul 3 '13 at 21:01
  • It's unclear to me how the Hamachi gateway is tripping the rogue DHCP server detection on the SBS 2003 machine. I don't believe the specific algorithm for the rogue DHCP server detection is published but it should be something like looking for unexpected DHCPOFFER packets. It is unclear to me why the Hamachi gateway would be "leaking" DHCPOFFER packets onto the LAN. – Evan Anderson Jul 3 '13 at 21:06
3

Yes, they assume that when you purchase SBS that it will be the only server in your environment providing DHCP services. SBS is targeted at a specific usage scenario and they expect that the people purchasing and deploying it understand how and why it fits into that usage scenario. The assumption is that you have reviewed it's operations and features before you deploy it and that you're deploying it because it's feature set is needed and understood. You can't blame them for developing a product aimed at a specific usage scenario and implementing features that serve that scenario. If you don't need or want the services provided by SBS then don't use it. I'm sorry if it sounds like I'm picking on you but I get tired of hearing people bash Microsoft because they think it's Microsoft's fault that their product doesn't fit perfectly in your environment.

You can easily disable the DHCP service on the SBS server and use the DHCP service provided by Hamachi.

  • I'm not bashing Microsoft at all- I just hope I can find a way to override this behaviour. I didn't install the server- it was already installed when I got here. It works fantastically for this environment, but having a DHCP server shut down without any warning can be pretty bad if you aren't expecting it. A troublemaker could bring in a home router with DHCP enabled, plug it into the network for a couple of hours, and bring the office to a standstill! Having the DHCP server service shutting down for an entire site is far worse that having an IP conflict or two... IMHO. – Austin ''Danger'' Powers Jul 3 '13 at 0:18
  • I gotcha. Again, no offense or disrespect intended. If Hamachi can serve the DHCP needs of your network then you can disable the DHCP service on the SBS server. – joeqwerty Jul 3 '13 at 0:20
  • I'm pretty sure Hamachi only gives IPs to VPN clients connecting to the gateway- that's why it's often referred to as a "virtual" DHCP server. It's not designed to replace DHCP on the LAN, and even if it was able to, I wouldn't want to stop using the server for this role as I like the tight integration between DHCP and DNS. – Austin ''Danger'' Powers Jul 3 '13 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.