I am using squid proxy 3.1 in ubuntu machine. I want to allow only urls matching our pattern through our proxy server. I configured acl like below. Acl for dstdomain is working fine. If i access any url besides .zmedia.com , I got proxy connection refused. But the url_regex is not working.

What i am trying here is.

Allow only request from ".zmedia.com" domain and the request url should be in "/blog" context.

# Recommended minimum configuration:
acl manager proto cache_object
acl localhost src ::1
acl to_localhost dst ::1

acl urlwhitelist url_regex -i ^http(s)://([a-zA-Z]+).zmedia.com/blog/.*$
acl allowdomain dstdomain .zmedia.com

acl Safe_ports port 80 8080 8500 7272
# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed 

acl SSL_ports port 443
acl Safe_ports port 80      # http
acl Safe_ports port 21      # ftp
acl Safe_ports port 443     # https
acl Safe_ports port 70      # gopher
acl Safe_ports port 210     # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280     # http-mgmt
acl Safe_ports port 488     # gss-http
acl Safe_ports port 591     # filemaker
acl Safe_ports port 777     # multiling http
acl SSL_ports  port 7272        # multiling http

# Recommended minimum Access Permission configuration:
# Only allow cachemgr access from localhost
http_access allow manager localhost
http_access deny manager
http_access deny !allowdomain
http_access allow urlwhitelist
http_access allow CONNECT SSL_ports
http_access deny CONNECT !SSL_ports
# Deny requests to certain unsafe ports
http_access deny !Safe_ports

# Deny CONNECT to other than secure SSL ports
http_access deny CONNECT !SSL_ports

# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost


# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow localhost

# And finally deny all other access to this proxy
http_access deny all

# Squid normally listens to port 3128
http_port 3128

# We recommend you to use at least the following line.
hierarchy_stoplist cgi-bin ?

# Uncomment and adjust the following to add a disk cache directory.
#cache_dir ufs /var/spool/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /var/spool/squid
append_domain .zmedia.com

# Add any of your own refresh_pattern entries above these.
refresh_pattern ^ftp:       1440    20% 10080
refresh_pattern ^gopher:    1440    0%  1440
refresh_pattern -i (/cgi-bin/|\?) 0 0%  0
refresh_pattern .       0   20% 4320

Please correct me , If i did anything wrong?

  • You should check the uri, since url_regex acl doesn't match https connections.
    – erick2red
    Jul 5 '13 at 19:14

Please try with this regexp:


The difference between yours and mine being ? after (s). This means that s in https can be present either 0 or 1 times.

  • Janne, Thank you for your response. I tried but it's not working.
    – kannanrbk
    Jul 4 '13 at 20:51

I solved this problem with cache_peer_access instead of cache_peer_domain.

  1. Create a regex file

$ vi /my-no-proxy.txt

Write regex in /my-no-proxy.txt

  1. Change squid.conf

vi /etc/squid/squid.conf

Add below to squid.conf

cache_peer my-proxy.com parent 8080 0 no-query name=myProxy
acl viaProxy dstdom_regex "/my-no-proxy.txt"
cache_peer_access myProxy deny viaProxy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.