When i am trying yum install phpmyadmin then i get this error

Error: Package: php-gd-5.3.3-22.el6.x86_64 (base)
           Requires: php-common(x86-64) = 5.3.3-22.el6
           Installed: php-common-5.5.0-1.el6.remi.x86_64 (@remi-test)
               php-common(x86-64) = 5.5.0-1.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
yum-3.2.29-40.el6.centos.noarch has missing requires of yum-plugin-fastestmirror

What do i need to do to fix that error


Then i get this

Repository epel is listed more than once in the configuration
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0: will be installed
--> Processing Dependency: php-gd >= 5.2.0 for package: phpMyAdmin-
--> Processing Dependency: php-php-gettext for package: phpMyAdmin-
--> Running transaction check
---> Package php-gd.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-22.el6 for package: php-gd-5.3.3-22.el6.x86_64
---> Package php-php-gettext.noarch 0:1.0.11-3.el6 will be installed

Packages skipped because of dependency problems:
    php-gd-5.3.3-22.el6.x86_64 from base
    php-php-gettext-1.0.11-3.el6.noarch from epel
    phpMyAdmin- from epel
  • Have you tried using "--skip-broken to work around the problem"? – Robbie Mckennie Jul 5 '13 at 13:32
  • @RobbieMckennie then i get this eror. See updated ques – JohnK Jul 5 '13 at 13:36
  • do you really need to use php-5.5? Could you show output of the following command # yum list installed | grep php – ALex_hha Jul 5 '13 at 14:07

The first error is because you have a newer version of PHP - specifically the php-common package - installed from the remi-test repo than the php-gd package can deal with. The easiest way to resolve the initial problem is to remove the remi-test repo, downgrade to the version of php-common provided in the base repo, then re-run the yum install phpmyadmin command.

  • how can i remoeve remi-test , repo and how can i downgrade the php-common – JohnK Jul 5 '13 at 13:47
  • How did you install the remi-test repo? If you isntalled a package for it like epel-release for the epel repo, remove that package. If you simply created the repo file, remove that file. – John Jul 5 '13 at 14:08

** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows: yum-3.2.29-40.el6.centos.noarch has missing requires of yum-plugin-fastestmirror

Yum version 3.2.49 requires yum-plugin-fastermirror pacakge. It seems like it is missing.

Can you run rpm -qa | grep fastestmirror and update your answer. If nothing appears, install the yum-plugin-fastestmirror via rpm directly.

There is a link where you can get directly the rpm http://zid-lux1.uibk.ac.at/linux/rpm2html/centos/6/os/x86_64/Packages/yum-plugin-fastestmirror-1.1.30-14.el6.noarch.html

  • I installed that and again i get the same error. rpm -qa | grep fastestmirror yum-plugin-fastestmirror-1.1.30-14.el6.noarch – JohnK Jul 5 '13 at 13:45
  • This is a problem, but it's unrelated to the immediate issue. – Michael Hampton Jul 5 '13 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.