I have a RAID-1 array on a desktop computer. The RAID controller is a 3ware 7006-2. Recently the controller has been reporting ECC errors from one of the drives. It was able to correct all of those errors, but I figured I better replace the drive before it dies.

I have successfully rebuilt the array with replacement drives before, but for some reason the RAID controller will not rebuild the array this time. It keeps saying that the replacement drive is "Not in Service: Rebuilding" and it remains stuck at 0% for several hours. (Previously when I rebuilt the array it only took about an hour.) I have tried using 3 different replacement drives and none work (all 3 stay stuck at 0%). I have also removed the good drive from the array and put in the bad drive (the one that had all the ECC errors) to see if I could rebuild the array using the bad drive, but that didn't work either.

Any ideas why my RAID controller is unable to rebuild the array now? Could the controller have gone bad, even though all the other functionality seems to be working? I can boot into the OS fine, it's just the rebuilding that won't work.

I know that this isn't a problem with the replacement drive being slightly smaller than the other drive in the array. Last year when I rebuilt the array, I had tried using a slightly smaller replacement drive and the controller gave an error about the drive being smaller and it wouldn't even let me start the rebuild. This time it did not display any error and let me start the rebuild, so I know the problem doesn't have to do with drive size.

One weird thing is this - the rebuilding progress stays stuck at 0%, unless I reboot the computer. Then the progress will say 1%, and it remains stuck at 1% until I reboot again. Then it says 2% and stays stuck at 2%... Maybe I should try rebooting my computer 100 times to see if the array is completely rebuilt after that?

  • This appears to be a bad port on the RAID controller. The good hard drive no longer boots from port 1, but it does boot from port 0 (which is strange, since it booted fine from port 1 yesterday, and also port 0 is where the replacement drive was plugged into and it couldn't do a rebuild). I just ordered the same RAID controller off ebay and hopefully that will solve the problem. Jul 6, 2013 at 5:43

2 Answers 2


I think it may actually be rebuilding but the progress indicator isn't correctly reflecting this. Either way it sounds like it could be a bug in the firmware. If you don't have the most recent firmware then try to flash the firmware with the newest version available, lsi should have them, see:


I have fixed strange problems like you describe by flashing the firmware with a newer version. In addition see if you can install the newest management software.


The problem was solved by installing another 3ware 7006-2 RAID controller. That controller lasted 2 years, because I am once again experiencing the exact same problems. Time to get another one off Ebay.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .