I'm trying to set up an SVN server on Linux (ubuntu, if it matters) and getting behavior that seems strange. When I'm on the actual server and try to just do svn list file://... it works and lists my test repo I have set up, but when trying to connect remotely from another server with svn list svn://... I get "No repositories found". All the google results I got told me it's usually an issue with the svnserve root path, but I've checked that three times now, and I know its right.


I assume you're running svnserve if you're trying to access the SVN using svn://, so check if svnserve is running. I know this is silly, but sometimes it does happen; being able to connect to SVN using file:// does not indicate if svnserve is running and configured properly.

To configure svnserve, check this tutorial.

I would suggest you configure SVN to be accessed by http: read here how you can do that.


I suggest using ssh+svn:// or https:// for accessing Subversion repositories, based on whether you want local users on your subversion server. In either case, my preference is for https://. You should find these more flexible than using svnserve.

  • I got the impression from my limited reading that http(s) was only for reading - i.e. you can't commit changes using it. Do you know of any setup information for your suggestions? – Alex S Aug 10 '09 at 7:45
  • I strongly support what David said, I'd configure your repositories to be accessed via https - read my answer below – Adam Benayoun Aug 10 '09 at 7:50
  • Is the svnserve run with correct permissions?
  • Have you checked the logs from svnserve (usually /var/log/ somehwere).
  • Try running the client with a verbose or debug setting (-v and -d in most programs).
  • Same, but for the server svnserve client.
  • Are you testing from localhost? If so, check that connecting over loopback (interface name lo) actually is permitted.

While I run SVN through Apache2 (HTTP + SSL), I do recall having difficulty debugging what's going on, as the SVN error messages can be a tad too generic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.