2

I’m looking for help with modifying Group Policy settings to control mapping of My Documents for users in a specific OU.

I’m working with a network of 2008 R2 domain controller and Windows XP & 7 clients. There is already a policy in place applying to all users that maps the My Documents to a network drive, and it has been working for several years. It is set to not allow manual changes.

The problem is we now have some users on remote sites connected via satellites. The high latency combined with My Documents mapped to the network location is causing the machines to be unusable due to delays, and it is causing us to go over our data caps.

I’ve tried putting these users in their own OU (sub-branch of where they were) with a copy of the policy modified to point My Documents to a path C:\LocalData. I’ve done a gpupdate force with a reboot. It appeared the policies were updated during reboot, but the new drive mapping policies did not take effect.

The only thing I can think of that could be causing this not to work, is I’m trying this with a computer that is not directly connected to the network, but using a vpn connection. So when rebooting, it does not have access to the domain controller. Shouldn’t this work anyway?

I'm using a Windows 7 client. For the policy I'm writing is:

User Configuration/Policies/Windows Settings/Folder Redirection/Documents

and I'm setting it to C:\LocalData\%USERNAME%\My Documents

Any suggestions on why this isn’t working, or on different way to accomplish this?

  • I suspect the GPOs you have are conflicting, but I honestly forget the rules for that. – Falcon Momot Jul 7 '13 at 20:48
  • Run a gpresults wizard against that user/computer. Are the correct policies being applied? – Zoredache Jul 7 '13 at 21:09
  • Have you tried breaking inheritance, just to rule out GPO conflicts? – Katherine Villyard Jul 7 '13 at 23:14
  • I ran gpresults and it looks like it should be getting the GPO, but there must be a conflict because it isn't giving the expected results. It's possible that rebooting off-network is causing it to not complete the implementation of the GPO. I'll try tomorrow when I can be on network when doing the gpupdate. I'll also try your suggestion of breaking inheritance to isolate. Thanks for the suggestions. – user2015032 Jul 8 '13 at 1:47
1

Found the problem was related to not being on network while rebooting. Once I put it on the network today and rebooted, the My Documents mapping followed the policies I was trying to apply.

Thanks for the input. Steve

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.