19

I connect to our Microsoft Server 2012 through remote desktop. There are just too many animations (for example Opening and closing windows) etc.

How do I turn off all animations?

25

Control Panel > System > Advanced system settings > Performance > Settings

Select the options that suit you. I normally select the option ""Adjust for best performance".

  • Glad to help. Note that these options haven't changed since at least Windows Server 2003. – joeqwerty Jul 9 '13 at 4:25
  • I'm more of a RHEL user, and hence my knowledge of Microsoft Server, is quite limited. – Devdatta Tengshe Jul 9 '13 at 5:30
  • it's particularly irritating that the "disable unnecessary animations" checkbox doesn't seem to have any effect – Andy Jul 9 '15 at 12:57
  • 1
    executes proposed solution on windows server 2016. expects it to work. clicks search icon in taskbar afterwards, and hey!....animations. wow. when will Windnoes finally die off? I long for the day. – Michael Trouw Feb 2 '16 at 10:09
7

You can also disable the animations in the Windows RDP client. Show Options -> Experience. On the MAC cleint you can adjust these options under RDC->Preferences->Display.

Good part about doing it at the client side is you can scale down the colors too and significantly speed up the paint times.

I can't comment on other clients though.

4

We have setup a group policy with the below which seems to help

Computer Configuration 
  Administrative Templates
    Do not allow Flip3D invocation Enabled  
    Do not allow window animations Enabled  
    Use solid color for Start background Enabled  

User Configuration (Enabled)
  Administrative Templateshide
    Do not allow Flip3D invocation Enabled  
    Do not allow window animations Enabled  

The solid color for start background is because of when we are providing remote assistance over a WAN link, background pictures slow things down. Though looking at it, I think we've put it in the wrong place, as I would of thought it should have been in the User Configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.