1

I've got the whole Nagios configured, it's working for a while now with many many hosts and everything is OK, except the one thing I've discovered. When I schedule a downtime for a host, it's sending notifications anyway. Is it some kind of a bug? What should I check/change please?

EDIT 1:
Nagios version: 3.4.1
Notification info:

***** Nagios *****

Notification Type: PROBLEM
Host: XXXX
State: DOWN
Address: xx.xx.xx.xx
Info: PING CRITICAL - Packet loss = 100%

Date/Time: Mon Jul 8 14:56:15 CEST 2013
2
  • Which version are you using? Could you please show us the full notification message? – quanta Jul 9 '13 at 9:07
  • I've edited my question, take a look. – Jakub Turcovsky Jul 9 '13 at 9:20
2

You need to thoroughly look at your configuration and your logs - I have never seen Nagios ignoring a scheduled downtime.

Note that there is a bug which might be related here, and is fixed in versions > 3.4.1.

7
  • In my other 3 versions of Nagios there wasn't any problem with this. I found nothing about scheduling downtime in my nagios.cfg file and I don't know where else to look, what else to check. – Jakub Turcovsky Jul 9 '13 at 9:34
  • My version is 3.4.1, so the bug could imho still be there. Do you think I should use the patch? I really don't like to mess with nagios core if there is other option, but if there isn't... – Jakub Turcovsky Jul 9 '13 at 9:36
  • 1
    I have seen notifications during downtime, too. But as Roman says, it came down to user-caused reasons every time. – Karma Fusebox Jul 9 '13 at 10:08
  • No, don't patch. Unless you know what it does, and you really, really need it. – Roman Jul 9 '13 at 10:10
  • @Roman: I really, really need to get downtime working. But the patch is the only mention about it. – Jakub Turcovsky Jul 9 '13 at 10:14
2

I have found the solution ! Go to your template.cfg file and change in the contact part :

FROM :

service_notification_options    w,u,c,r,f,s      ; send notifications for all service states, flapping events, and scheduled downtime events
host_notification_options       d,u,r,f,s      ; send notifications for all host states, flapping events, and scheduled downtime events

TO :

service_notification_options    w,u,c,r,f      ; send notifications for all service states, flapping events, and scheduled downtime events
host_notification_options       d,u,r,f      ; send notifications for all host states, flapping events, and scheduled downtime events

Remove the "s" there remove the mail notification from nagios for scheduled downtime event.

1
  • This is few years old and I don't have Nagios anymore so I cannot verify your answer. But if you get enough upvotes from the community, I'm going to accept your answer as correct. – Jakub Turcovsky Jul 11 '16 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.