1

For some reason the Broadcom Advanced Control Suite 4 seems to be a little buggy OR I have not configured something correctly.

I have 4 Gb NICs and I team 3 of them to make a virtual adaptor...

NIC_1 - mac: 180373f039c8 - ip: n/a (disabled)

- TEAMED -
NIC_2 - mac: 180373f039ca - ip: TEAMED (VIRTUAL_NIC)
NIC_3 - mac: 180373f039cc - ip: TEAMED (VIRTUAL_NIC)
NIC_4 - mac: 180373f039ce - ip: TEAMED (VIRTUAL_NIC)

VIRTUAL_NIC - mac: 180373f039ca - ip: 10.71.1.4

Now on my ASA5505 I get the following error all the time.

Received ARP request collision from 10.71.1.4/1803.73f0.39ca on interface servers
with existing ARP entry 10.71.1.4/1803.73f0.39cc

Seems to me that IP address 10.71.1.4 should always be connected/associated with MAC 180373f039ca (the first NIC in the team). For some reason it's changing from packet to packet... OR at least randomly sometimes.

Ideas?

3

The software is doing exactly what you asked it t (likely "Smart Load Balancing and Failover" is the choice you picked). This type of "teaming" causes the NICs to "share" the server computer's IP address and the ASA is "seeing" this as an anomaly and reporting it. In order to obtain a load-balancing effect the Broadcom driver must do this because, otherwise, all clients would respond to the same NIC within the "team".

If you choose 802.3ad link aggregation, which will require your Ethernet switch to participate in the "teaming", you will alleviate the message you're "seeing". The NICs will all use a single virtual MAC address and the switch will handle load-balancing the traffic across all the links in the "team". The ASA won't "see" any anomaly.

  • Thanks Evan! That helped out a BUNCH! It was exactly what I needed to get me on the right path! – Arvo Bowen Jul 12 '13 at 6:37
  • I'm glad I could help. I hope you don't mind but I'm not approving that edit because it's a little too localized for your needs and I'd like the answer to stay more generic. – Evan Anderson Jul 12 '13 at 6:55
0

EXACT STEPS TO GET RID OF THE ARP ERRORS

Note: This was using a Dell PowerConnect 2848 and Broadband Advanced Control Suite adaptors on a Dell PowerEdge R610 connecting to an ASA5505.

Step 1: Set up your switch to handle the LAG (team) you will create (on the
server using the Broadband Advanced Control Suite).

Step 2: Change the type of team you are using (in the Broadband Advanced Control
Suite) from a "Smart Load Balancing(TM) and Failover (SLB)" to a "FEC/GEC Generic
Trunking" DO NOT USE the "802.3ad Link Aggregation using Link Aggregation Control
Protocol (LACP)".  I also used the option "Enable HyperV Mode".

Step 3: Change settings on the Hyper-V network.  Server Manager (MYSERVER)->
Roles->Hyper-V->Hyper-V Manager->MYSERVER, right click 'Virtual Network Manager'.
On the virtual adapter that is created, make sure it's
'External' (BASP Virtual Adapter) and check the checkbox under it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.