The linux server where exim service is running is under no load.

The system is sending email successfully but is taking a long time to send each email.

Basically if I telnet to localhost port 25 and then I try to send an email from there the response from the server is super slow. The mail application we have running there is taking more than 8 minutes to send 4 emails.

Has anyone confronted this issue before with EXIM and maybe you might now what is the setting that is making EXIM wait so long for something. I am looking at the logs and I cannot see anything indicative of an error. Below a sample of the mainlog:

2009-08-10 07:21:05 H=(aurl.domain.ni) [] Warning: Sender rate 4.6 / 1h
2009-08-10 07:21:29 1MaTsX-0000mw-Oe <= stgbouncing@theperfectplace.net H=(aurl.domain.ni) [] P=esmtp S=22003 id=67402024.1249906753667.JavaMail.root@aurl.domain.ni
2009-08-10 07:21:54 SMTP command timeout on connection from (domain.com) []
2009-08-10 07:22:42 1MaTsX-0000mw-Oe ** thegroupofbouncing123@earthlink.net R=lookuphost T=remote_smtp: SMTP error from remote mail server after RCPT TO:: host mx3.earthlink.net []: 550 thegroupofbouncing123@earthlink.net...User unknown
2009-08-10 07:22:42 1MaTti-0000nM-3b <= <> R=1MaTsX-0000mw-Oe U=mailnull P=local S=23089
2009-08-10 07:22:42 1MaTsX-0000mw-Oe Completed

3 Answers 3


The server appears to be doing throttling which might affect you if you are testing from one IP:

2009-08-10 07:21:05 H=(aurl.domain.ni) [] Warning: Sender rate 4.6 / 1h

Often issues like this are related to poor DNS. Exim does a lot of resolution during processing mail. Check the DNS config on the Exim server. Check the performance on the DNS server it is using.

Is the server doing any DNSBL processing? I'm often asked to look at servers exhibiting poor performance and it turns out they are using DNSBLs that have been retired, meaning lookups are timing out.

Try running exim in debug on the server to see where the problem is. The following will run an Exim daemon on port 26, staying attached to the console and printing lots of debug:

exim -bd -d -oX 26

Then telnet to tcp/26 instead of tcp/25 and test as you had been.


DNS is a common issue, as jj33 suggested.

Exim may be configured to do an ident lookup on incoming email. For a long time this defaulted to a 30 second timeout - I'm not sure if this is still the case. Delaying mail slightly helps a lot with spammers I've found (naive spammers will push the mail anyway, which then lets you trigger on protocol violation errors), so it's worth doing still IMO.

# RFC1413 lookups can cause timeouts. (ident)
rfc1413_hosts = *
rfc1413_query_timeout = 5s

rfc1413_hosts defaults to *, so if you want to disable it, try

rfc1413_hosts = 
  • Excellent answer. This can easily be skipped if the SMTP clients are trusted.
    – molf
    Jan 19, 2012 at 12:49
  • I can't say if this is the right answer for the OP, but it sure solved it for me. Well, almost - I set "rfc1413_query_timeout = 0s" as described in the config file comments. Dec 2, 2013 at 12:28

Mine was damn slow and after I deactivated a certain modifier (dnslists) in the vexim-acl-check-rcpt.conf file, my mails are now very fast in sending. Seems like the the modifier I was using is invalid though it came with the vexim package. Further investigation shows that the dnslist zen.spamhaus.org:list.dsbl.org seems to be invalid. So I deactivated it and worked fine too. Hope it helps someone else in a way. This is my vexim-acl-check-rcpt.conf file

*# deny message = DNSBL listed at $dnslist_domain\n$dnslist_text

dnslists = zen.spamhaus.org:list.dsbl.org

deny message = DNSBL Blacklisted dnslists = list.dsbl.org deny message = DNSBL Blacklisted dnslists = dnsbl.sorbs.net deny message = DNSBL Blacklisted dnslists = rhsbl.sorbs.net deny message = DNSBL Blacklisted dnslists = bl.spamcop.net*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.