I have a Hyper-V VM running Windows Server 2008 R2 (Host is also WinSrv 2008 R2) that was working perfectly. It has now started BSOD before I even login. On testing if I boot normally and login the vm Blue Screens after 1min 35seconds. If I safe boot this extended to almost 4 minutes.

The hex I get on the BS is 0x000000F4 etc.

I dont have time to check out the eventlog within the vm itself before it explodes but the event log on the host reports the following warning....

Log Name: Microsoft-Windows-Hyper-V-Integration-Admin Source: Microsoft-Windows-Hyper-V-Integration-KvpExchange Date: 7/11/2013 12:53:38 PM Event ID: 4130 Task Category: None Level: Warning Keywords:
User: NETWORK SERVICE Computer: --- Description: Virtual machine 'ZeroThree' has an older version of integration services installed ('6.1.7600.16385'). To help avoid compatibility problems, upgrade integration services in the guest operating system to '6.1.7601.17514'. (Virtual machine ID 'FE5F168E-FE73-438B-82BA-9258E1F3E8E6')

I have tried to upgrade the integration services but it only gets half way through the install before another BSOD.

All other VM's (Running same os) are working fine.

I have also bounced the host server.

Any suggestions, tips, pointers would be most gratefully received.



  • Try migrating the (off) VM to another host, see what happens there. – TomTom Jul 11 '13 at 12:40
  • Unfortunately I don't have another host running hyper-v I can test on. Nice idea though. – Paul Hale Jul 11 '13 at 13:15
  • if you want to read the eventlog leave the vm powered off then mount the vm as a disk then locate the log and open it up within eventview. More then likely nothing useful will be there, at that point follow @stephane steps. – tony roth Jul 11 '13 at 14:01
  • also you can use dism to inject the newest IC's into the offline image, hopefully you had a backup of all this! – tony roth Jul 11 '13 at 14:03
  • found a good link for offline ic updates blogs.technet.com/b/virtualization/archive/2013/04/19/… – tony roth Jul 11 '13 at 14:05

This bubcheck code means that some critical thread or process has been terminated.

Now, the way to deal with bluescreens (beside the usual "let's google the error code") is to:

  1. Get the memory dump or at least, the minidump. In your case, since the machine doesn't start, you can do it by mounting the system VHD from the host (it's usually located in the c:\windows\minidump or directly at the root of the C drive, but that can change)
  2. Save the dump on a machine that has the Windows Debugging Kit installed (see there).
  3. Run dumpchk.exe from the WDK with the !analyse parameter. That will tell you more precisely what happened and give you more indication about the probable cause of the bugcheck.

I have written a very simple batch to perform that analysis. It will grab the appropriate symbols from MS's web site so you don't have to download them beforehand:

set sympath=C:\WinDebug\symbols

c:\WinDebug\dumpchk.exe !analyze -v -y srv*%sympath%*http://msdl.microsoft.com/download/symbols %1 > c:\tmp\%~n1.txt 
notepad c:\tmp\%~n1.txt

(Just pass the dump file as parameter to the script. You'll need to adjust the path to match your system).

  • Thanks for all your help & advice with this. Tried installing integration services but Powershell says Mount-VHD cmdlet is missing. Also tried exploring minidump folder but folder does not exist on the server. I also tried searching for any *.dmp files but none were found. I have mounted the vhd and backed up all the database files I need so am in the process of building another vm. Would still like to fix the existing broken vm just to gain a little experience though. Have set the vm not to auto boot after a BSOD in the hope the minifile would be created but alas it is still not generated. – Paul Hale Jul 15 '13 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.