3

I have a virtual machine that I'm backup up using Veeam Backup & Replication 6.5. The software is working well, but one issue I'm having is that at the end of the backup (99%) the machine will freeze from anywhere from 2 - 5 minutes. This makes backing up servers in the middle of the day next to impossible because of the workflow disruption it causes.

The reason I'm not contacting Veeam in this regard is because I had just switched to Veeam, where before it was Acronis vmProtect however it did not always do this. The same thing happened, only with that backup software I could see "Removing Snapshot" in the tasks pane of vSphere. I assume the removal of the snapshot is what causes the problem in Veeam as well.

During this freezing it halts all features of the server and I get an error when attempting to access the console stating Error Connecting to the MKS: Error Connecting to the /bin/vmx process. Research of that line points to corruption of the vmx file, however I don't think that's the case as that message is only present during the end of a backup.

I have another virtual guest being backed up with Veeam B&R on the same host and it does not present the problems outlined above.

Does anyone know what the issue here might be?

EDIT : Storage system for local backups is a Drobo i800 connected via iSCSI. Storage for offsites is a NAS box on a RAID 1

EDIT 2 : vSphere version is 5.0 and VMWare Tools is installed. Guest OS is Server 2008 R2 64 Bit, and if I connect to the console before snapshot removal begins the screen will go black and the /bin/vmx message shows up in the top of the screen after about a 20 second delay of seeing only black on the console screen.

4
  • Tell us about your storage system. – ewwhite Jul 11 '13 at 14:14
  • @ewwhite Question edited; please let me know if you require further storage information. Please note that it freezes regardless of whether it's on local backups or offsite. – DKNUCKLES Jul 11 '13 at 14:40
  • What version of vSphere and do you have the VMTools installed and running? What is the guest OS? If you connect to the console before the snapshot removal process starts, are you still able to work on the system at all? – Rex Jul 11 '13 at 14:42
  • @Rex updated for clarity. – DKNUCKLES Jul 11 '13 at 14:51
2

This issue was resolved by deleting an existing shapshot that existed (presumably from another borked backup job).

Snapshot was deleted and the consolidation at the end of the backup goes without a hitch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.