I've installed GitLab, following the given official instruction, but I'm getting 502 error when trying to use it. Nginx log entry:

 *30 upstream prematurely closed connection while reading response header from upstream, client: 95.27.118.xx, server: gitlab.somehost.net, request: "GET /users/sign_in HTTP/1.1", upstream: "http://unix:/home/git/gitlab/tmp/sockets/gitlab.socket:/users/sign_in", host: "gitlab.somehost.net"

As I remember from the previous GitLab installation experience, the error cause is that GitLab is initializing at the first user access, and nginx thinks, that it's timeout, so the solution is increasing some timeout value. The problem is I didn't remember which timeout I should increase (this solved the error for me with the previous installation), and Google doesn't help me.

  • github.com/gitlabhq/gitlabhq/issues/1527 See the reply by Chacham15
    – Michael
    Jul 11, 2013 at 20:57
  • @Cocoabean I don't have unicorn.rb file in config directory. Update: The "puma" is now used in the GitLab, not the Unicorn
    – artem
    Jul 11, 2013 at 21:08

2 Answers 2


Increasing RAM solved the problem.


https://github.com/gitlabhq/gitlabhq/issues/1527#issuecomment-12313207 mentions it should be changed in unicorn.rb

  • Puma is used instead of unicorn in the GitLab.
    – artem
    Mar 2, 2014 at 21:00
  • We switched back to Unicorn some time ago. Aug 17, 2014 at 13:09
  • is it possible that someone fixes those installation bugs or are they simply ignored? I´m struggeling around for days now to get this piece of ... working Jan 30, 2015 at 23:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .