2

I have recently starting testing the SUP capability of SCCM 2012. I have followed the guides to set up the Server and all seems to be working fine. Updates are being downloaded and showing on the server console.

However on the client side there seem to be a few teething problems. The clients are showing that they need the updates but aren't downloading them.

I checked WUAHandler.log and found this error repeated regularly.

Its a WSUS Update Source type ({804E0972-01D9-479F-8E38-E58576D82725}), adding it. WUAHandler 12/07/2013 12:18:16 3216 (0x0C90)
 Existing WUA Managed server was already set (HTTP://Ourservername.LOCAL:8530), skipping Group Policy registration. WUAHandler 12/07/2013 12:18:16 3216 (0x0C90)
 Added Update Source ({804E0972-01D9-479F-8E38-E58576D82725}) of content type: 2 WUAHandler 12/07/2013 12:18:16 3216 (0x0C90)
 Scan results will include superseded updates only when they are superseded by service packs and definition updates. WUAHandler 12/07/2013 12:18:16 3216 (0x0C90)
 Search Criteria is (DeploymentAction=* AND Type='Software') OR (DeploymentAction=* AND Type='Driver') WUAHandler 12/07/2013 12:18:16 3216 (0x0C90)
 Async searching of updates using WUAgent started. WUAHandler 12/07/2013 12:18:16 3216 (0x0C90)
 Async searching completed. WUAHandler 12/07/2013 12:18:17 5284 (0x14A4)
 OnSearchComplete - Failed to end search job. Error = 0x80244022. WUAHandler 12/07/2013 12:18:17 3216 (0x0C90)
 Scan failed with error = 0x80244022. WUAHandler 12/07/2013 12:18:17 3216 (0x0C90)

I had a look at Scanagent.log and this was full of red. Mainly repeating the same 0x80244022 error but also a 0x87d00631 error.

Sources are current, but Invalid. TTL is also invalid. ScanAgent 12/07/2013 12:18:14 6104 (0x17D8)
 ScanJob({2821C25B-DD2A-4505-B406-CB4642515CF9}): CScanJob::OnScanRetry- Requesting scan ScanAgent 12/07/2013 12:18:15 6104 (0x17D8)
 No CatScan history exists ScanAgent 12/07/2013 12:18:15 3216 (0x0C90)
 ScanJob({4A6446FE-72C7-46E6-AF39-7D6BCD2DC337}): CScanJob::OnScanComplete -Scan Failed with Error=0x80244022 ScanAgent 12/07/2013 12:18:15 5240 (0x1478)
 ScanJob({4A6446FE-72C7-46E6-AF39-7D6BCD2DC337}): CScanJob::ScheduleScanRetry- ScanRetry Timer task successfully scheduled. Will wake up in next 1798 seconds ScanAgent 12/07/2013 12:18:16 5240 (0x1478)
 ScanJob({4A6446FE-72C7-46E6-AF39-7D6BCD2DC337}): CScanJob::OnScanComplete - Scan Retry successfully scheduled ScanAgent 12/07/2013 12:18:16 5240 (0x1478)
 Sources are current, but Invalid. TTL is also invalid. ScanAgent 12/07/2013 12:18:16 3216 (0x0C90)
 ScanJob({4A6446FE-72C7-46E6-AF39-7D6BCD2DC337}): CScanJobManager::OnScanComplete- Scan has failed, scan request will be pending for scan retry cycle. ScanAgent 12/07/2013 12:18:16 5240 (0x1478)
 CScanAgent::ScanCompleteCallback - failed at OnScanComplete with error=0x87d00631 ScanAgent 12/07/2013 12:18:16 5240 (0x1478)
 ScanJob({2821C25B-DD2A-4505-B406-CB4642515CF9}): CScanJob::OnScanComplete -Scan Failed with Error=0x80244022 ScanAgent 12/07/2013 12:18:17 5240 (0x1478)
 ScanJob({2821C25B-DD2A-4505-B406-CB4642515CF9}): CScanJob::ScheduleScanRetry- ScanRetry Timer task successfully scheduled. Will wake up in next 1798 seconds ScanAgent 12/07/2013 12:18:17 5240 (0x1478)
 ScanJob({2821C25B-DD2A-4505-B406-CB4642515CF9}): CScanJob::OnScanComplete - Scan Retry successfully scheduled ScanAgent 12/07/2013 12:18:17 5240 (0x1478)
 ScanJob({2821C25B-DD2A-4505-B406-CB4642515CF9}): CScanJobManager::OnScanComplete- Scan has failed, scan request will be pending for scan retry cycle. ScanAgent 12/07/2013 12:18:17 5240 (0x1478)
 CScanAgent::ScanCompleteCallback - failed at OnScanComplete with error=0x87d00631 ScanAgent 12/07/2013 12:18:17 5240 (0x1478)

I've trawled around the web looking for likely causes but come up blank. I was wondering if anyone could shed some light on the problem.

Also very weirdly last night the scan did work and in WUAHandler I got this.

Its a WSUS Update Source type ({804E0972-01D9-479F-8E38-E58576D82725}), adding it. WUAHandler 12/07/2013 06:43:27 5468 (0x155C)
 Existing WUA Managed server was already set (HTTP://Ourservername.LOCAL:8530), skipping Group Policy registration. WUAHandler 12/07/2013 06:43:57 5468 (0x155C)
 Added Update Source ({804E0972-01D9-479F-8E38-E58576D82725}) of content type: 2 WUAHandler 12/07/2013 06:43:57 5468 (0x155C)
 Scan results will include superseded updates only when they are superseded by service packs and definition updates. WUAHandler 12/07/2013 06:43:57 5468 (0x155C)
 Search Criteria is (DeploymentAction=* AND Type='Software') OR (DeploymentAction=* AND Type='Driver') WUAHandler 12/07/2013 06:43:57 5468 (0x155C)
 Async searching of updates using WUAgent started. WUAHandler 12/07/2013 06:43:57 5468 (0x155C)
 Async searching completed. WUAHandler 12/07/2013 06:44:51 592 (0x0250)
 Successfully completed scan. WUAHandler 12/07/2013 06:46:56 2568 (0x0A08)
 The new content version (4) of update source is less than before (5), continuing. WUAHandler 12/07/2013 07:28:10 5468 (0x155C)

But then throughout the day today I have the same errors as before. If anyone can shed any light as to why this is happening and how to remedy it then it would be much appreciated.

1

0x80244022 means Same as HTTP status 503 - the service is temporarily overloaded. (Source: Windows Update Agent)

I would suggest this is a problem with the actual WSUS component, the fact it ties in with a HTTP 503 would explain why it sometimes works and sometimes doesn't. Seeing if you get anything interesting in WindowsUpdate.log on the client would be useful as well to see the extent of the problem and pinpoint it a little more.

In my opinion though this is a WSUS problem rather than ConfigMgr, could also be a problem with the proxy server if you go through one as well. Just for reference 0x87d00631 translates to Scan retry is pending.

1
 OnSearchComplete - Failed to end search job. Error = 0x80244022.

This error can be caused by many different issues related connectivity or access to the WSUS web server.

In my case I found that IIS Application Pool (WSUSPool) had crashed / stopped.

According to the blog linked below this is a common issue caused by not enough memory being allocated to the app pool.

http://blog.coretech.dk/kea/house-of-cardsthe-configmgr-software-update-point-and-wsus/

  • 2
    Link-only answers are considered to be sub-par on SF. Please provide content here and then link elsewhere for more details if necessary. – EEAA Mar 16 '16 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.