8

Take the following system, a Supermicro VMware ESXi host with Intel Westmere E5645 CPUs. enter image description here

Part of our deployment process is to set the appropriate Enhanced vMotion Capability (EVC) level for the vSphere cluster to avoid problems during possible future expansion. The Intel E5645 CPU is a mid-range Westmere CPU. However, VMware does not allow us to set EVC for this CPU model. It does work if we drop one level to the "Nehalem" mode.

What is the reason for this?

enter image description here

enter image description here


Update:

The Intel AES-NI feature was disabled in the BIOS on the host servers. Enabling it allowed me to use the Westmere EVC level.

enter image description here

enter image description here

  • 2
    How about you scrap that thing and get an HP. – Michael Hampton Jul 12 '13 at 21:00
  • @MichaelHampton I think he'd love to, don't tempt him ;) – Shane Madden Jul 12 '13 at 21:03
9

Looks like VMware KB 1034926 specifically covers this.

some Westmere micro-architecture processors that have AES/PCLMULQDQ features disabled are not permitted into Intel Westmere (Xeon 32nm Core i7) EVC clusters. If these features cannot be enabled in the BIOS, the host will only be admitted to the Intel Nehalem Generation mode or below.

Hopefully the Supermicros have a way to enable these features? If not, you're stuck in Nehalem mode.

  • Grrrr... I haven't had this issue with HP boxes... but you're suggesting that there's a BIOS setting that could control this? – ewwhite Jul 12 '13 at 20:57
  • @ewwhite Yeah, or there ought to be (VMware's hint says (look for "AES" or "Advanced Encryption Standard").), but it depends completely on whether Supermicro has actually implemented a lever in the BIOS to manage it. If there isn't one in there now, see if there's a newer version of the BIOS, they might have an update to add a control for it. – Shane Madden Jul 12 '13 at 21:00
  • Or should I just not bother with EVC at all? – ewwhite Jul 12 '13 at 21:02
  • @ewwhite I'd say spend a bit of time trying to get it working -- it has potential to save a lot of headache with cluster migrations down the road. But if Supermicro's BIOS won't let you enable the features, then it might be better to skip it for this cluster instead of going Nehalem mode. – Shane Madden Jul 12 '13 at 21:05
  • 1
    This process worked. The Intel AES-NI feature was disabled in the BIOS on the host servers. Enabling it allowed me to use the Westmere EVC level. – ewwhite Jul 12 '13 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.