13

I have a client machine running ubuntu, and I have a windows server 2012 that I connect to using rdesktop.

I need to copy a file from my client machine to the server. I tried sharing a directory like this:

rdesktop -u username -p password -r disk:mydisk=/home/mydir server_IP

I have no idea how to access this shared directory. I have never used rdesktop or windows server before.

please help.

3
  • same issue here...\\tsclient is empty. Did you ever find a fix?
    – capdragon
    Sep 18, 2013 at 17:05
  • 1
    no. it is still empty for me...
    – akonsu
    Sep 18, 2013 at 17:57
  • Please read my answer; it should provide you with the solution. Apr 27, 2014 at 14:27

6 Answers 6

17

It seems that specifications for RDP (MS-RDPEFS) have changed. In specific Windows versions, you also have to forward audio in order to get disk forwarding to work.

4
  • 7
    Thanks, this tip worked for me (rdesktop 1.8.1)! rdesktop -r disk:... -r sound:local:alsa made by share finally show up in Server 2012.
    – hmn
    Feb 12, 2014 at 16:42
  • 2
    It's completely insane that this actually works. Mar 3, 2015 at 23:49
  • 1
    Do you know if the same trick can be used in remmina?
    – Esteve
    Jun 11, 2015 at 15:17
  • 3
    This worked and both made and ruined my day...
    – Bryan
    Jul 9, 2015 at 15:33
5

Try adding -r sound:local to your command.

The final command should look like this:

rdesktop -u username -p password -r disk:mydisk=/home/mydir server_IP -r sound:local

1

Open up Explorer. It should show up in Computer with other drives.

1
  • thanks, but I do not see it there. Please refer to my comment under RobW's answer.
    – akonsu
    Jul 13, 2013 at 1:33
0

For this example, I'm naming your host Ubuntu1.

Using this command to access launch rdesktop from Ubuntu1:

rdesktop -u rob -p Password1 -r disk:mydisk=/home/mydir 10.0.0.126

I connect to 10.0.0.126 just fine. I open Windows Explorer and look at the bottom of my list. Just below my Z: drive, I see a drive icon and mydisk on Ubuntu1

I can save files to it, and they appear on Ubuntu1 in directory /home/mydir.

2
  • 1
    in my case it does not show in windows explorer. I can see \\tsclient, but it is empty. The windows server that I am using is AWS EC2 instance, maybe I need to configure something?
    – akonsu
    Jul 13, 2013 at 1:32
  • The instructions are fine. I just tried them. Up voted.
    – Shoan
    Dec 30, 2015 at 8:03
0

EDIT: If you know about \tsclient and you know it is empty, this answer is not for you.

How to access correctly shared drectory from remote windows server: While in remote session on windows server, it should be listed in Computer among other drives. If it is not, try typing \\tsclient in address bar in Computer. To be specific, your shared directory should be accessible at \\tsclient\mydisk.

0

Enabling the Sound also works for Remmina to addresss missing shared drive issue. I believe remmina and other RDP clients for Linux just use rdesktop to complete the connection.

Just change the dropdown option on Sound to Local, and voila, the specified shared folder will now show up. Also fixes missing printers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.