I'm trying to mount a WebDAV share as a drive on Windows 8. I've tried setting up WebDAV server on both Windows 2012 and Debian Linux, but both yield the same error when attempting to mount from client.

I have verified that the Linux WebDAV works through cadaver-command, it authenticates successfully with the credentials given and I am able to download files. I can also use a browser to access it successfully from client using these credentials. So WebDAV server seems to work.

Windows 8 client however gives me this error:

C:\>net use *
System error 67 has occurred.

The network name cannot be found.

I get the same error if I try to mount using Windows Explorer. "/webdav/" is the subdirectory I have configured for WebDAV access on the server.

There is no firewall blocking access to server. As I mentioned I am able to connect using browser, so network is not the issue.

Are there any additional steps required to get this working and/or am I doing something wrong?

Edit: Logs from Apache says the following (hostnames has been changed to protect the innocent):

==> /var/log/apache2/other_vhosts_access.log <==
debian1.my.net:80 - - [13/Jul/2013:17:53:00 +0200] "OPTIONS / HTTP/1.1" 200 229 "-" "DavClnt"
debian1.my.net:80 - - [13/Jul/2013:17:53:03 +0200] "OPTIONS /WebDAV HTTP/1.1" 200 193 "-" "Microsoft-WebDAV-MiniRedir/6.2.9200"
debian1.my.net:80 - - [13/Jul/2013:17:53:03 +0200] "PROPFIND /WebDAV HTTP/1.1" 405 584 "-" "Microsoft-WebDAV-MiniRedir/6.2.9200"

I'm also able to access WebDAV using .Net and SharpBox.

2 Answers 2


Found the Solution: Basic auth.

Change BasicAuthLevel to 2 under HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

Then restart WebClient service:

net stop WebClient
net start WebClient

My Apache2 config for those interested:

NameVirtualHost *
<VirtualHost *>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/webdav/mounts
        <Directory /var/www/webdav/mounts>
                Options Indexes MultiViews
                AllowOverride None
                Order allow,deny
                allow from all

        Alias /webdav /var/www/webdav/mounts

        <Location /webdav>
           DAV On
           AuthType Basic
           AuthName "webdav"
           AuthUserFile /var/www/webdav/passwd.dav
           Require valid-user


Edit: Ended up configuring WebDAV to use Digest so it works without modifying registry on Windows client. Posted result here in case anyone is interested.


If your server is running linux it is possible that the path might be case-sensitive.

This error can also be caused by bad credentials; try specifying the /user option.

  • Good catch, but sadly that was just a typo in my question. I was using correct casing when accessing. Posted Apache log entries as well, from the logs we see it actually uses "WebDAV" instead of "webdav" as my Alias (Apache config) says - so something magical is happening here. :) Jul 13, 2013 at 16:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .