0

I'm having trouble trouble opening port in SQL Server 2008 R2 Express Edition (http://www.microsoft.com/en-us/download/details.aspx?id=30438) even by disabling the Firewall. I also installed the official requirements needed on the instructions without issues.

My configuration is the following :

  • The SQL server is install on a Vmware machine, part of a domain, the firewall is disabled, ping is fully working.

  • In SQL Server Manager > SQL Server Network Configuration > Protocols ... > Shared Memory and TCP IP is enabled (Names pipes and VIA disabled).

  • My IP address in TCP/IP protocols is enabled, dynamic port disabled, and the port set as 1433. The rest is left at the default values
    (disabled).

  • By following netstat -an (with the Administrator domain account) I got the following result:

         Active Connections
    
         Proto  Local Address          Foreign Address        State
         TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
         TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
         TCP    0.0.0.0:47001          0.0.0.0:0              LISTENING
         TCP    0.0.0.0:49152          0.0.0.0:0              LISTENING
         TCP    0.0.0.0:49153          0.0.0.0:0              LISTENING
         TCP    0.0.0.0:49154          0.0.0.0:0              LISTENING
         TCP    0.0.0.0:49155          0.0.0.0:0              LISTENING
         TCP    0.0.0.0:49156          0.0.0.0:0              LISTENING
         TCP    0.0.0.0:49672          0.0.0.0:0              LISTENING
         TCP    192.168.1.12:139       0.0.0.0:0              LISTENING
         TCP    [::]:135               [::]:0                 LISTENING
         TCP    [::]:445               [::]:0                 LISTENING
         TCP    [::]:47001             [::]:0                 LISTENING
         TCP    [::]:49152             [::]:0                 LISTENING
         TCP    [::]:49153             [::]:0                 LISTENING
         TCP    [::]:49154             [::]:0                 LISTENING
         TCP    [::]:49155             [::]:0                 LISTENING
         TCP    [::]:49156             [::]:0                 LISTENING
         TCP    [::]:49672             [::]:0                 LISTENING
         UDP    0.0.0.0:123            *:*
         UDP    0.0.0.0:500            *:*
         UDP    0.0.0.0:4500           *:*
         UDP    0.0.0.0:5355           *:*
         UDP    127.0.0.1:57998        *:*
         UDP    127.0.0.1:58165        *:*
         UDP    127.0.0.1:64371        *:*
         UDP    192.168.1.12:137       *:*
         UDP    192.168.1.12:138       *:*
         UDP    [::]:123               *:*
         UDP    [::]:500               *:*
         UDP    [::]:5355              *:*
    

Again, the firewall is disabled, ping is working, but it sill impossible to have 1433 open.

I also restarted the whole machine several times, but it didn't change anything.

PS : This is installed on a VMware machine (Windows server 2008), in bridged mode, installed on a different machine than the Active Directory server (Windows server 2003)

Can anyone help me ... ?

  • Surely if the firewall is disabled then there is no port to open so your problem is elsewhere. It looks like nothing is listening on port 1433 from your netstat output. What do your SQL server logs say ? – Iain Jul 15 '13 at 9:42
0

Have you configured SQL Server to listen for remote connections?

EXEC sys.sp_configure N'remote access', N'1'
GO
RECONFIGURE WITH OVERRIDE
GO
  • Hello, mrdenny. Yes I did ... by following this tutorial : msdn.microsoft.com/en-us/library/ee248622%28v=vs.90%29.aspx – Guillaume Néry Jul 15 '13 at 11:44
  • Is it a named instance or the default instance? – mrdenny Jul 15 '13 at 11:54
  • It's a named instance ! – Guillaume Néry Jul 15 '13 at 13:16
  • Can you screenshot and post the SQL Server config Manager, specifically Config Manager > SQL Server Network Configuration > Protocols for {instance name} > TCP/IP properties on the IP Addresses tab? – mrdenny Jul 15 '13 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.