0

Our mx records point to a different IP address than our main public address. However the mail being sent, SMTP is pointing to our main public IP address. The email using the address that SMTP is using is not being accepted by Gmail. I have checked all of our workstations and servers and there is no virus or malware present to indicate that unsolicited spam email is being sent out. How can I change the IP of the SMTP mail to use the same public IP address as the mx record, (mail.domain.com) address? I am assuming that the reason Gmail is blocking our email is because of the IP address being blacklisted. Our mail server IP address is not blacklisted, however. I am going crazy trying to get Gmail to unblock us; they do so for 2 or 3 days and then block us again. I don't know what else I can do.Thank you for your help.

1

It would have been helpful if you'd provided details of the MX, and headers from incoming and ouitgoing email.

It sounds like your outgoing email is not routed via the same MTA as the incoming email. This is not an unusual situation, and on its own would rarely be sufficient for a service provider to consider your server as a spam source. Either you are routing your email via a provider who is well known for spamming or you're publishing invalid SPF/RMX data.

Another potential cause is that you are running an open relay/your email server has been compromised and is being used to send UBE (or you are sending UBE yourself).

  • I'm sorry. Here is the additional information. the MX record is mail.empressems.com 24.38.44.132. The IP address that is blacklisted is 24.38.44.130 and this is the address on the return header for Gmail is this: There was a SMTP communication problem with the recipient's email server. Please contact your system administrator. <appsrv2.empressems.com #5.5.0 smtp;550-5.7.1 [24.38.44.130 7] Our system has detected that this message is> – Marie OKeefe Jul 15 '13 at 16:10
  • @MarieOKeefe This information should be added to your question. – Michael Hampton Jul 15 '13 at 17:25
  • Too bad...that should be an option. So then I guess I just have one question. like I said Gmail keeps blocking our IP address. Each time this happens, should I just wait for the address to become unblocked or is there something else I can do? I have already filled out their form online. Does filling out this form really expedite the block removal. Thanks so much for your help. – Marie OKeefe Jul 17 '13 at 15:22
0

Exchange always uses the IP with the lowest numeric value to send out emails - in your case that would be the .130 one instead of the .132.

And no, you can't select an IP for Exchange to use. Bizarre! The only way around seems to be either to remove all lower IP addresses from your network card configuration if you can live with not having the .130 in your server. OR: To use a 3rd party program that is able to route outgoing SMTP traffic via a specific local IP rather than use the default one that Exchange uses.

You can use MultiSendcon (http://www.servolutions.com/multisendcon.htm) for this. MultiSendcon originally is a send connector that can route outgoing emails to different SMTP relay servers but it also can route email directly (dns) without any relays and via specific local IPs. It's originally a product to support different domains going out via different IPs but you can just add one single direct-dns account there with the desired local IP 24.38.44.132 and tag that "*" for all senders.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.