-1

TWC 80Mbps

Cisco ASA 5510 (MTU 1500)

Download speeds on my Windows and Mac machines are ~200KB/sec. If I use a download manager that opens 20 concurrent connections I can hit the full 8MB/sec. I thought okay maybe it's a problem with a switch or the firewall so I plugged my test machines directly into the fiber connection and still same issue.

My previous Internet 60Mbps connection was using a point-to-point dish and I was able to nearly max it out with my Windows/Mac machine without using a download manager.

I thought maybe it was an MTU issue but I haven't had the chance to test it, but at the same time, if it worked with the old connection why do I need to adjust the MTU?

My question is, is there something on the Cisco ASA that I can tweak or anything else? Is there a configuration change that I should try?

2
  • so I plugged my test machines directly into the fiber connection and still same issue - I assume this means you bypassed the ASA alltogether? If not, then you weren't really "directly into the fiber" – Mark Henderson Jul 16 '13 at 1:07
  • Hi mark. Yes I bypassed the ASA altogether. – Michael Jul 17 '13 at 15:00
3

Check duplex and port speed specs. Fiber handoff from twc sometimes requires hard coded values for this. Start with speed 100 duplex full.

They should be able to tell you what they require. Maybe upgrade firmware and asdm while you are at it.

2
  • I hard coded the values so speed is 10Mbps and duplex = full. Caused my Internet to break completely – Michael Jul 17 '13 at 15:00
  • Trying different speed values 10,100,1000 also caused the Internet from working only Auto worked. Duplex didn't change speed. – Michael Jul 17 '13 at 15:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.