1

on my windows Server I'd like to install a imap server. Through HTTP the server is reachable, but if I try to connect using IMAP the server does not respond, instead if I disable the firewall it works fine.

The Firewall allows all outgoing connections and as I do not use ssl for this first try I opened port 143 for incoming connections. Is there something else to configure in the internal windows firewall?

  • Please post your rule for imap? – cuonglm Jul 17 '13 at 7:15
  • On the "Protocol and Port"-Tab Local Port is set to "Specific local ports" on Port 143. As Remote Port I did allow all ports. On the General Tab I set allow Connection. The rest I left on default settings – john84 Jul 17 '13 at 7:21
0

I would assume that your firewall profile does not match the rule/location you're in.

Windows firewall is dynamic, it knows where you are, and it knows that based on your location, it should apply a certain set of rules that are predefine or that you have defined your self.

Just try to make sure that the location you're in matches the rule you created.

For more information, read this: http://blogs.technet.com/b/networking/archive/2010/09/08/network-location-awareness-nla-and-how-it-relates-to-windows-firewall-profiles.aspx

  • But I made sure that my rule applies on all three Profiles. – john84 Jul 17 '13 at 7:23
  • Allow me to ask, rule created on the "Inbound Rules", not outbound? – Noor Khaldi Jul 17 '13 at 7:32
  • On Inbound Rules – john84 Jul 17 '13 at 8:08
0

After enabling the "Edge Traversal"-Option it works, but i am not aware about what it is.

Update

Now I think that I know what Edge Traversal is thanks to that Question: Windows Advanced Firewall: What does "Edge Traversal" mean?.

Through that question I found also a good post on configuring the Windows Firewall: http://www.windowsecurity.com/articles-tutorials/firewalls_and_VPN/Windows-Server-2008-Firewall-Advanced-Security-Part2.html

0

Allowing Edge Traversal didn't work for me when I tried to open up just port 143. Here is the Windows 7 firewall setting I had to use to allow other computers to connect to my hMailServer. Starting from a new firewall rule:

  1. Rule Type: Program
  2. Program: Set This program path: to %ProgramFiles% (x86)\hMailServer\Bin\hMailServer.exe (or browse to the location of hMailServer.exe for your installation)
  3. Action: Allow the connection
  4. Profile: In my case, I selected Domain and unchecked all others. Adjust this to your needs though I would obviously not allow Public unless you really, really want to open it up to everything.
  5. Name: hMailServer.exe Program Access or whatever you want to name it.

After that, everything worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.