7

First of all I want to request you all not to mark this query as duplicate, as I tried to find out the problem but was unable to do so.

I already has IIS installed and was working fine but suddenly it stopped working. There was no installation of new software or removal of any software and service.

First I uninstalled the IIS by unchecking it from the Programs and Feature -> Turn windows feature on or off. Then again installed IIS and windows publishing service.

so, the boxes that are checked are Application development feature are:

  1. .net extensibility
  2. ASP
  3. ASP.NET
  4. ISAPI Extension
  5. ISAPI Filters

And the boxes that are checked under windows publishing service are :

  1. Process Models.

Then I restarted my system and then tried to start IIS server and I got this error.

Cannot start service W3SVC on computer '.'.

So, I searched the net and found that I should do

net stop w3svc
net stop IISAdmin
net start IISAdmin
net start w3svc

net start IISAdmin -- > the service name is invalid

net start w3svc  --> the dependency service or group service failed to start

And even I did iisreset /restart then the output was:

Attempting stop...
Internet services successfully stopped
Attempting start...
Restart attempt failed.
The IIS Admin Service or the World Wide Web Publishing Service, or a service dependent on them failed to start.  The service, or dependent services, may had an error during its startup or may be disabled.

Then I even didn't find IIS Admin in services.msc.

Guys, please help me out...

Let me know if you need any more information.

Thanks in advance.

2
  • Any events in the eventlog? Jul 17 '13 at 16:39
  • Was there a solution to this problem? Jan 9 '18 at 4:15
1

If you’re having problems with the w3svc service

Try this first

Go to Task Manager > Processes and manually stop the W3SVC process. After doing this the process should start normally when restarting IIS

Try this second

Run > appwiz.cpl > Turn windows features on or off > Uncheck “Internet Information Services” and “Windows Process Activation Service”

Restart your machine. Run > appwiz.cpl > install both “Internet Information Services” and “Windows Process Activation Service”

Then this…if it still doesn’t work

  1. Confirm that “Windows Management Instrumentation” is started and its startup type is set to automatic.

  2. Also make sure the following dependency services are started for World Wide Web Publishing Service:

Windows Process Activation Service Remote Procedure Call (RPC) DCOM Server Process Launcher RPC Endpoint Mapper.

  1. Open regedit, navigate to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP]:

a) Double click on Start and change value data from 4(disabled) to 3(automatically). b) Delete “NoRun” key if this key exists.

  1. Uninstall “Internet information Service” and “Windows process activation service(if it is already installed)” from “Turn windows feature on or off” and Restart your PC.

  2. Type the below command in CMD and press enter:

net start http Now it will notify you that service is already running.

  1. Reinstall Internet information Service from “Turn windows feature on or off”.

Verify C:\Windows\System32\inetsrv\config\applicationHost.config looks correct. Check for a “system.web” section in this file which may be causing problems. Remove the section.

  1. Make sure these 2 services running and their startup type is automatic.If they are disabled and not running right click on them and go to properties and change them.

Windows process activation service Worldwide web publishing service

  1. Start IIS and my websites are started now, no more “w3svc service is not running error.”

  2. Restart computer.

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .