2

Background: I have a windows server 2012 install with AD, DNS and DHCP.

I also have a netopia router/modem providing my WAN access.

My router/modem is configured with DHCP off and connected to a 24 port switch. My WS2012 has static IP and uses the router/gateway as its default gateway for internet traffic and uses loopback for DNS. This WS2012 is also connected to same 24port switch.

The Problem:

My DNS server has forwarding enabled to my ISP's dns servers.

Here is the problem: All my workstations on the network are getting extremely slow internet access (.1-.2 Mbps). Connecting directly to the modem and setting static IP (and completely bypassing the WS2012) gets about 4-5 Mbps. The reason I think this is a DNS issue is because whenever I go into DNS manager and clear the Cache the internet on all machines runs at 4-5 Mbps for about 10-20 minutes and then slows to crawl again.

I have already checked my reverse lookup records and forward records and they seem to be in-tact.

This issue just arose about 1 week ago and this WS2012 has been in production for 6-7 months without a single hickup. No configuration changes have been made to this machine. Nobody has even logged into this machine (headless) since put into production besides a monthly reboot (from login screen via RDP).

PS. All internal traffic runs at full speed.

  • 1
    odd...what happens if you change forwarders to something like 4.2.2.2 or 8.8.8.8? – TheCleaner Jul 18 '13 at 13:59
  • 1
    So workstations have GW set as netopia router, but when DNS is set to WS2012 after a while their access gets slow? when it is slow. have you tried doing NSlookups to see if dns resolution is indeed taking a long time? but also this would only affect loading pages, etc. once it gets the answer, file downloads/etc should not be affected as they are not using DNS. The normal way I would set something up like this is disable DHCP in the router, enabled DHCP / DNS in the WS server, and set forwarders int the server to the upstream caches. – Doon Jul 18 '13 at 13:59
  • TheCleaner: so I initially had forwarders set to google's dns as you mentioned with ISP as fallback. This had worked for the last 6-7 months flawlessly. @Doon This is what does not make sense to me either since DNS is only used for lookup of IP and initial page load. However when running speedtest.net after clearing cache its 4-5Mbps and then after 10-20 minutes as mentioned it slows to about .1-.2. Now what is the part you mentioned about "set forwarders int the server to the upstream caches." this part i am not sure about. – Dhruvb14 Jul 18 '13 at 14:05
  • (i am not windows guy). but AD needs to be the master DNS, and all workstations needs to use it else naming breaks, etc. also it seems to work better when the Domain is in control of everything(DNS/DHCP/etc...) So the router is just a router, disable DNS and DHCP on it, letting the windows server do those functions It just becomes the default gateway.. Then inside your windows server in the dns snap in, under actions-> properties you should have a forwarders tab, that you can use your ISP (or googles servers). This way local queries are local, but unknowns get forwarded and then cached) – Doon Jul 18 '13 at 14:17
  • 2
    Welcome to Server Fault. If you solved your own problem, please post it as an Answer and then accept it by clicking the check mark next to your own answer. This is not a forum, and so it's not necessary to put things such as "SOLVED" in the question title. – Michael Hampton Jul 19 '13 at 4:25
1

So it worked fine with 8.8.8.8 as the original forwarder but not with your ISP's DNS servers?

That would seem to be the issue then, that your forwarders you have in place are causing slow DNS resolutions. You can easily confirm if DNS is causing this. Just use FileZilla and FTP into an FTP site via IP address (not FQDN) and then transfer a large file from that FTP site to you. If it runs at the right speed, then your issue is DNS resolution (and probably just your forwarders).

  • I had it working fine with 8.8.8.8 as dns for 6-7 months no issues. About a week ago these issues arose. I changed dns to ISP thinking that was issue but it was not since the internet was very fast when i cleared dns cache from inside dns manager on WS2012. After a little bit of time (10-20 min) it becomes slow again. – Dhruvb14 Jul 18 '13 at 15:53
  • Can you try the FTP via IP test and see what bandwidth results you are getting? You need to start narrowing it down. – TheCleaner Jul 18 '13 at 17:53
  • 1
    Ok so i solved the issue and this a new one. So the previous sysadmin had opened up the router to put a dedicated External IP on the server. With the new install there were no external services running on the machine(Email, webserver, etc)so i setup the DNS server with open modifications from outside since I assumed (My fault) that it was providing strictly internal dns functions. Well the domain started getting dns update requests on from tons of different places and it looks like that was causing slow down and thats why clearing cache worked for a bit. Removed static IP and it works now. :) – Dhruvb14 Jul 19 '13 at 4:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.