We're just about to roll out a bunch of Lenovo T431s's but have an odd problem with the NICs on them.

Basically (from reboot) they are taking too long to initialise (i.e. the blue "swirl" on the system tray LAN icon takes about 5 seconds to disappear). (If you log off without rebooting, and log back on, the login script runs fine.)

Another peculiarity is that the icon then comes up with the yellow warning triangle even though the network is working. (You can browse the internet / ping etc)

The NIC is the Intel 82579LM. Have tried it with version (latest driver from the Lenovo site) and version (latest from the Intel site). The only other thing worth noting is that there is vPro on the machines.

Any suggestions how I can speed up the initialisation, or delay the script to wait for the network?

  • 1
    Configure the switch ports that connect to host devices for whatever the equivalent of portfast is on your switches. – joeqwerty Jul 19 '13 at 12:10
  • Think it must be a driver issue on the NIC. If I log on via wifi the login script works. I also tried connecting via a USB-Ethernet dongle - also works fine. Evidently something specific to this NIC. – Ben Jul 19 '13 at 12:38
  • I'm almost certain @joeqwerty is correct, but another thing that can cause issue like this is speed negotiation. IF you can set both ends to auto/auto. – tony roth Jul 19 '13 at 18:41

You could configure your logon script to run synchronously... i.e.: wait for the network to come online.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.