3

I'm trying to install the remote desktop web access role in server 2012, a simple task you might think, however whenever I try to do this, I get this error:

add-windowsfeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The specified module could not be found. Error: 0x8007007e
At line:1 char:1
+ add-windowsfeature rds-web-access
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],
    Exception
    + FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind
   owsFeatureCommand

This is from trying to install via powershell, but I get the same error via the GUI and using DISM.

This is a fresh out of the box server 2012 server. I have wiped and re-installed windows to no avail. I have tried using Dism with the sources switch to point to the 2012 media, same issue. The server is connected to a WSUS server for updates, but I have added the registry keys so that it can use Windows Update for any feature content it needs, I have also moved it to not use the WSUS server and go straight to Windows update, same issue.

Other features install fine (RD gateway for example) but I cannot get RD web access to install. I have also manually installed all the pre-req components (iis, asp.net 4.5 etc) and the error still occurs.

Any suggestions greatly appreciated.

1

Some things to check:

  • Make sure there are no entries in HKLM\System\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations. If there are, reboot to get them processed. Or do the renames manually and delete them.
  • Run DISM /Online /Cleanup-Image /RestoreHealth to clean up the component store.
  • Don't install on a Domain Controller.
| improve this answer | |
  • Thanks, I didn't know about point one, will check that now, however I have reboot a number of times. I've run the cleanup, and its not a DC, its a plain member server. – Sam Cogan Jul 19 '13 at 15:06
1

So I managed to resolve this by doing another clean install and then using the command below to install. Not sure why it worked this time.

add-windowsfeature rds-web-access -source f:\sources\winxsx
| improve this answer | |
0

You may use DVD as a source also.

  1. Find an index of a distributive:

    dism.exe /get-imageinfo /imagefile:d:\sources\install.wim
    
    Deployment Image Servicing and Management tool
    Version: 6.3.9600.17031
    
    Details for image : d:\sources\install.wim
    
    Index : 1
    Name : Windows Server 2012 R2 SERVERSTANDARDCORE
    Description : Windows Server 2012 R2 SERVERSTANDARDCORE
    Size : 6,898,373,863 bytes
    
    Index : 2
    Name : Windows Server 2012 R2 SERVERSTANDARD
    Description : Windows Server 2012 R2 SERVERSTANDARD
    Size : 12,051,460,352 bytes
    
    Index : 3
    Name : Windows Server 2012 R2 SERVERDATACENTERCORE
    Description : Windows Server 2012 R2 SERVERDATACENTERCORE
    Size : 6,871,511,192 bytes
    
    Index : 4
    Name : Windows Server 2012 R2 SERVERDATACENTER
    Description : Windows Server 2012 R2 SERVERDATACENTER
    Size : 12,065,366,117 bytes
    
    The operation completed successfully.
    
  2. Pass the path and index to the Source parameter:

    Add-WindowsFeature Web-Mgmt-Tools -Source WIM:D:\sources\install.wim:2
    

See the article for details.

| improve this answer | |
0

Taken from here: https://blogs.technet.microsoft.com/dcaro/2012/12/17/installing-remote-destop-web-access-role-on-windows-server-2012/

Remove the SSL certificate from the localhost binding.

  • Verify if you have any SSL certificated bound to your default website. Don’t use the IIS Manager console, it will very likely not show you the reality. Use the following command : netsh http show sslcert

Check if you any certificates bound to “any address” on port 443. They will appear like that :

IP:port : 0.0.0.0:443 Certificate Hash : 23cadab1b5e066d126eea139c28459bbf30c6d5c Application ID : {00000000-0000-0000-0000-000000000000} Certificate Store Name : MY Verify Client Certificate Revocation : Enabled Verify Revocation Using Cached Client Certificate Only : Disabled Usage Check : Enabled Revocation Freshness Time : 0 URL Retrieval Timeout : 10000 Ctl Identifier : (null) Ctl Store Name : (null) DS Mapper Usage : Disabled Negotiate Client Certificate : Disabled

  • Remove this certificate from the certificate store by using the following command :

Netsh http delete sslcert ipport=0.0.0.0:443

Only the certificate bound to any IP on port 443 is supposed to cause the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.