While trying to install a program, it complained that something else was being installed and that Windows Installer was already running (msiexec.exe). Sure enough, there were two instances of the process with one of them using 25% CPU (quad core, so basically 100% of one core).

After searching online, I ran across this: http://support.microsoft.com/kb/2793634 titled "Windows Installer starts repeatedly after you install SQL Server 2012 SP1" which says:

"After you install SQL Server 2012 SP1 on a computer, the Windows Installer (Msiexec.exe) process is repeatedly started to repair certain assemblies." ... "When this issue occurs, you experience high CPU usage."

Has anyone encountered this or been able to fix it? I just thought it would be a good idea to have this question here with a solution for future reference, since this is a huge problem. It's impossible to install any software after installing SQL Server 2012 SP1.

  • 2
    Have you killed the msiexec.exe processes and installed the update linked in the article? Or paused the NGEN service to install the update? Jul 19, 2013 at 18:05
  • As @Cole stated, what have you tried so far to fix the issue? You should add those "tries" to your post so that others will benefit.
    – TheCleaner
    Jul 19, 2013 at 18:09
  • The first fix seems to have worked. It's annoying, because this is a clean install of the OS, with just SQL Server and Visual Studio 2012 installed. I run Windows Update and then all of the sudden I can't install programs anymore. Not good. Anyway, it's fixed now.
    – Triynko
    Jul 19, 2013 at 19:22

1 Answer 1


I ran the very first suggested hotfix and it seems to have fixed the problem: http://www.microsoft.com/en-us/download/details.aspx?id=36215

I didn't have to register to get an email or any of that other annoying stuff that some hotfixes require. I just downloaded that and ran it. It performed some "stop check" first and suggested I should shut down MSIEXEC manually to "avoid restarting the system", but the Services manager wouldn't let me stop it, so I just ignored it and let it keep running anyway.

There were a few setup steps, and then after about a half hour of installation it finished and didn't require a restart. I was able to immediately install other apps. Problem solved for now.

  • 1
    Please mark this as the answer.
    – Greg Askew
    Jul 19, 2013 at 20:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .