I recently installed Windows Server 2003 on a virtual machine and then added the IIS role.

(The reason for using an old OS is to make some old software work - Crystal Reports web server component)

I have not yet added any pages/apps to the website (except one very simple test html page with 'hello' paragraph tag in it before the re-installation of iis), but no matter what I try I get 'Service Unavailable' when browsing localhost or when browsing the site from outside the server.

I have tried the steps listed here - http://support.microsoft.com/?id=918041

I have tried the steps listed here - http://support.microsoft.com/kb/842493 (even though the machine is not a domain controller)

I have tried gradually giving more and more 'freedom' to the wwwroot folders to the various user/system accounts involved. No matter what I try - 'Service Unavailable'

Each time I try the site, the event viewer shows a series of warnings - "A process serving application pool 'DefaultAppPool' terminated unexpectedly. The process id was 'xxxx'. The process exit code was '0xffffffff' each with a different process id, and then "Application pool 'DefaultAppPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

I also tried removing the IIS role, then re-adding it (but this time - without the APS.net component)

The server is fully updated.

Any ideas?

  • Sam, is this an ASP classic or ASP.NET app? Did you try something more simplistic (like a "Hello world" script) to see if your IIS base configuration works out okay and is executing ASP scripts? What are the recycling / memory limit settings for the pool?
    – the-wabbit
    Jul 20, 2013 at 11:49
  • It is neither. It's the fresh installation of IIS. I did add a 'test.html' page with <p>Hello</p> in it, but browsing to that just gives Service Unavailable. Edit: The penny just dropped - 'Sam' :)
    – MrVimes
    Jul 20, 2013 at 12:02

2 Answers 2


Make sure that the IUSR and ASP.NET user accounts have permissions to read the folders that the virtual directory is pointing to in the CRweb installation. You may also need to add read/write for these users on Windows\temp, if memory serves.

And make sure that the correct version of the .Net framework is selected for the application pool. These always got me back when I was using the CRweb server.


My default answer these days, but:

  1. Download Process Monitor (Microsoft SysInternals)
  2. Configure a filter for process name = w3wp.exe and turn on "drop filtered events"
  3. Do an IISRESET
  4. Clear your process monitor log
  5. Browse to your site

Then review the output to see if there are any obvious issues, such as Access Denied, Etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.