0

To possibly fix an error, I was told to set the correct permissions to a user:

Make sure that ftp user of your repository has permissions for:
  • change directory (cd)
  • list directory (ls)
  • create directory (mkdir)
  • remove directory (rmdir)
  • upload file (put)
  • download file (get)

Can you help me to do each step please, how to set?

CentOS 6.4 (with proftpd / xinetd), user is already created named "test1234".

  • If you are using chroot that is set by default in proftpd then you probably don't need to do anything. Because user has all these privileges in home dir. – ALex_hha Jul 20 '13 at 20:38
  • @ALex_hha : this was working already fine (by default), until the latest plesk upgrade to version 11.30, then there is a curl transfer permission error when trying to move a backup to the backup server and I was told to check out this list in the question. I thought already about to remove the user and add a new user, that should do the trick too, but since I was told to check out the list, I wanted to learn how to do this, setting each permission for a user. – user160248 Jul 20 '13 at 20:49
0

Assumes that the user is chrooted into their home directory, you could try something like

<Directory ~user>
   <Limit DELE, MKD, RMD, ...>
     AllowUser user
   </Limit>
</Directory>

You can get more info at http://www.proftpd.org/docs/howto/Limit.html

P.S. Also I will suggest to check permissions on the file system.

  • The main problem is a bug in Plesk with a / that causes the error, but your answer is the correct answer to my question. Thank you. – user160248 Jul 21 '13 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy