I have an IIS web server on my local network for development purposes, and I want to disable all caching mechanisms. IIS seems to be caching everything, even when I disable output caching like so:

Output Caching window

I have set the above at the root of my webserver.

The weird thing is that I need to request a file a few times before it starts caching it.

I know that it can't be a client side related issue as I checked that they were requesting a fresh copy from the server each time.

Example of what I did:

  1. I create a HTML file
  2. I navigate to the above HTML file on the server (e.g. http://example/path/to/file/test.html) in my browser, and refresh the page a few times.
  3. I change the HTML file on the disk
  4. I refresh the page in my browser again, but I still see the old HTML file, and not the new one that I had saved to the disk in step 3.

IIS version: 7.5, Windows version: Windows 7

Can anyone help me please?

  • 1
    Are you sure it's not the client that's doing the caching here. Have you tried clearing the client browser cache after you change the file on the web server? – Chris McKeown Jul 23 '13 at 11:46
  • @ChrisMcKeown Yes, I am sure that the problem is server side - I have cleared the cache in between page loads. – starbeamrainbowlabs Jul 23 '13 at 11:57
  • Any proxy servers in between the client and the server that might be doing the caching? – Chris McKeown Jul 23 '13 at 11:59
  • You should be able to look at the headers to see what it's throwing at you. If you get a 304 Not Modified response then something in between is caching your results. – Nathan C Jul 23 '13 at 12:44
  • 3
    Have you found the solution to this problem? I'm experiencing the same issue and can't disable the goddamn cache in any way – Tivie Dec 8 '13 at 1:16

I realize this an old thread. However, I'm having the same issue and having trouble finding more information about it.

What may help though is a somewhat related article explaining this exact issue, where disabling Output caching the IIS way didn't help. What these guys did was disable/remove the module altogether. This is the only promising bit of information I have at the moment.

Here's the (old) post: https://www.lightmaker.com/get-your-iis-output-caching-right-for-sitecore-multisite-implementations/

Update: This hasn't resolved my issue, so there is something else in my case causing the caching. I'll leave the reply in in case it does help someone else.

  • 1
    I don't have a windows machine handy to test this on anymore, but this sounds like the best solution I've seen yet. If it works for you I'll accept this as the answer :D – starbeamrainbowlabs Apr 5 '17 at 9:24
  • Unfortunately, this hasn't resolved our issue. – Effing May 5 '17 at 17:28
  • Awww, drat! If you do ever find a solution - do keep us updated :-) – starbeamrainbowlabs May 6 '17 at 12:35

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.