3

I've set up nginx and mailman (among everything else) via this tutorial: http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-nginx-bind-dovecot-ispconfig-3-p4

I was able to successfully create a mailing list (called braindexter-pre-registration) and have received the welcome email, but whenever I try to access the admin page to add members or send an email, I get a (mostly) blank page that says 403.

I get the error if I visit http://192.168.1.12:8081/cgi-bin/mailman/admin/braindexter-pre-registration, and if I visit http://192.168.1.12/cgi-bin/mailman/admin/braindexter-pre-registration, I just get the Welcome to nginx! screen.

Here is what my error log says when I use port 8081:

2013/07/24 19:10:35 [error] 12255#0: *32 FastCGI sent in stderr: "Cannot chdir to script directory (/usr/lib/cgi-bin/mailman/admin)" while reading response header from upstream, client: 192.168.1.11, 
server: _, request: "GET /cgi-bin/mailman/admin/braindexter-pre-registration HTTP/1.1", upstream: "fastcgi://unix:/var/run/fcgiwrap.socket:", host: "192.168.1.12:8081"

Here is what my access log says when I use port 80:

192.168.1.11 - - [24/Jul/2013:19:12:31 -0500] "GET /cgi-bin/mailman/admin/braindexter-pre-registration HTTP/1.1" 304 0 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.36 
(KHTML, like Gecko) Chrome/27.0.1453.116 Safari/537.36"

I am completely stumped here as to how to proceed. I have tried following the suggestions in http://forum.nginx.org/read.php?2,227508,227508#msg-227508 but that doesn't seem to have helped.

closed as off-topic by HopelessN00b Mar 1 '15 at 3:55

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.