6

We have 3x 3TB WD Red drives configured in a RAID 5 on an HP P812 controller with the latest firmware on.

However, drives keep being dropped randomly from the array upon reboots, though not always. It's always only one drive being dropped at a time and the problem doesn't seem to affect the WD Raptor, also connected to the P812. ACU reports that the affected drive is "missing or not connected properly" and the diagnostics simply reports that the drive is missing. Hot-reinserting the drive causes the controller to see the drive again, but requires a reboot to make the logical drive available again and so the cycle continues. All drives connect properly to the array in about 1 in every 5 reboots.

All 4 drives are connected to the internal port 5i using a Mini SAS SFF-8087 to 4 SATA fan out cable.

We tried this configuration in two different (non HP) environments but the same problem affected both.

We also tried the disks on a P800 and they worked fine there (although, given the P800 limitations, only 2TB of the disks were being recognised).

What could possibly be causing this problem?

3
  • 1
    Does the controller specify a list of certified compatible drives? Are your drives among those? – Halfgaar Jul 25 '13 at 11:33
  • I couldn't find a such a document from HP. As for WD, they basically said that they test their Red drives with NAS enclosures only - their intended market space - and will direct you to their enterprise drives for server applications. Having said that, so far as I know, the difference between Reds and RE4s lies in their performance and reliability, and Reds, being engineered for NAS enclose with RAID set ups, should perform acceptably in light enterprise applications. But I might be wrong... – Seb Boulet Jul 25 '13 at 12:02
  • You won't find a document. But SATA drives do work. I don't think I'd ever use a breakout cable on a Smart Array controller, though. – ewwhite Jul 25 '13 at 12:52
4

It's the fanout cable arrangement...

I have drives like this that work in external HP enclosures and in HP servers where there are internal 3.5" bays and a proper backplane.

Does this mean that you're not using an HP server? What are you using? Where are the disks? How are they connected to power? Molex connectors direct to the drive? Molex power injectors on the SATA breakout cable? You're not using them on a backplane, so you're not taking advantage of hotswap, etc.

Finally, are you SURE you upgraded the firmware of the controller to the latest revision? You may have to do this from within the OS if this is not an HP server.

5
  • The drives are powered with molex connectors directly on the drives, so yeah, no hotswap until we source an MSA60... It's not an HP server and the controller was upgraded in the OS with the HP firmware utility and ACU is reporting it as having the latest version. – Seb Boulet Jul 25 '13 at 13:03
  • Can I ask why you're so sure the fanout cable is the problem? – Halfgaar Jul 26 '13 at 10:33
  • @Halfgaar Because I've run several thousand HP servers over the years and have a lot of experience with the controllers, disk arrangements and drive types. The drives the OP is using aren't bad. The controller isn't bad. Using the disks with a SATA breakout cable and no backplane is bad. That's not how the controller is meant to be used. Maybe a SAS breakout cable would be better, but the best solution is a backplane or an external enclosure. – ewwhite Jul 26 '13 at 12:06
  • 1
    I have sourced an MSA enclosure and the drives have been running in the enclosure without a problem for a couple of weeks now. Thanks. – Seb Boulet Sep 18 '13 at 21:57
  • @SebBoulet Very good! – ewwhite Sep 18 '13 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.