I am using Symantec Ghost Corporate Edition (centralised server et al) version 11 to ease deployment of new desktops, and I am having a couple of issues.

At the moment we have a very very basic use of Ghost in place - we use GhostConsole to deploy a client to a prepared computer, then to sysprep it and grab the image. We then use GhostConsole to deploy that image other (identical hardware) computers, and this in general works fine. Although we know Ghost can do much much more, we have yet to actually tap into this and have been using the above process for about a year.

Two questions:

  1. When we use GhostConsole to sysprep and grab the image, the source computer seems to be left in a state where you cannot reboot it back into its own image - it always reboots to the PCDOS Ghost environment and awaits the GhostCast server. Is there any way to get this computer back into a usable state after taking the image, without redeploying the image?

  2. This is related to my first question - I have just taken an image of a desktop that took a while to setup. The image grabbing went fine and without issue, but the image cannot be redeployed as it is corrupted and every attempt to ghost a system using that image fails. Is there any way to save this image? As question 1 indicates, the source computer is now useless to me so I cannot retake the image, and I don't want to break the bad news to the support staff that their time was wasted!

Cheers Richard



I've had the problem from 1 happen while deploying images before. Ghost creates a partition for its use and then doesn't delete it. I've been able to create a boot disk and put like fdisk or something similar on there. I've then deleted the ghost partition and marked the Windows partition as the active partition.

For 2, as far as I know, once an image is taken, that's it for that image. However, if my first answer fixes 1, then you can just retake your image. Also, what type of PC's are you ghosting? I've had trouble in the past w/ IBMs and Ghost (something about the IBM software, if we wanted to image an IBM, we had to just reformat the things and start over from scratch).

Good luck!

  • Dustin, thanks for the answer - we are imaging several different types from both Fujitsu and HP. While we do have some older Fujitsus that will not Ghost at all (cant find the hard disk), they generally work OK with some small percentage of failures as noted by dyasny. I will try your bootdisk suggestion, but I feel that its a wasted cause in this case, as I already tried to redeploy the image taken (as there was no indication it was corrupt at that time) :( – Moo Aug 11 '09 at 13:30
  • When you deploy the corrupt image, what's happening to make you say it's corrupt? – Dustin Aug 11 '09 at 13:54
  • Dustin, its failing during the deployment, with Ghost saying the image is corrupt. – Moo Aug 11 '09 at 15:42
  • Ah. If you've deployed the corrupt image (or tried) to the original computer, then the bootdisk won't help at this point (but it can in the future if that partition gets stuck). We typically had the workstation that we took the image from and one where we did a test deploy. Also, we ran into the partition problem if we did the ghosting from the console (not using the ghost boot disk). Depending on the number of workstations, that might be an option. – Dustin Aug 11 '09 at 16:31
  • For the older Fujitsu's, remove the drives and ghost them in another machine. – Robin Gill May 6 '12 at 21:55

I'm no expert on ghost, but ghostcast uses UDP, which is uncontrolled. That means an image might get corrupted on the way to the imaged host, and all you can do is reimage.

From my experience using gjostcast deploying 400+ workstations back in the win98 days, about 10-15% had to be reimaged again because of this corruption

  • Can you just restart the reimaging from the same computer? As I noted in my question, the computer is left in an 'unusable' state after the imaging has occurred, is there a way to fix that or can you just take the image while its in this state? – Moo Aug 11 '09 at 11:28
  • If you run sysprep on the computer, you can't reverse the effects of resealing. – dyasny Aug 11 '09 at 16:01

Re #1 - I don't know about V11, but on older versions you could fix it by typing Ctrl+C to exit the ghostcast session and then type:

 ngctdos -hide

Re #2 - I've had issues imaging Lenovo laptops. I now image just the OS partition rather than the whole disk. I believe the problem is to do with the MBR - You can fix the MBR on the target laptop after imaging, but it's easier just to image the partition. It has the added benefit of using less disk space on your ghost server too.


To exit the command line, type ctrl+c then type ghreboot. As for the corruption, I face the same problem tomorrow at work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.