1

I have a test setup that has 2 Windows Server 2012 VMs on Hyper-V joined to a windows 2008 R2 domain - there is an internal network whose DNS server is on the domain controller and an external network whose DNS server is also a Windows 2008 R2 box.

All Cluster validation tests pass.

When I get to the first screen in the Create Cluster Wizard which asks for the Cluster Name, no matter what I type in the box, I get the error "The network name {0} is already used in the network" - the error comes back almost immediately and there are no events in the System or Application logs of any of the servers.

I have Windows 2008 R2 VMs with clusters on this exact setup. I'm happy to post more information, but I don't even know where to start looking at this point.

Thanks

  • Do you have a default DNS record configured on your internal DNS? – Chris S Jul 29 '13 at 13:53
  • I'm not sure I understand the question - possibly not - I followed some directions I found (a while ago) to configure the DNS server and it worked with my Win 2008 R2 clusters - haven't touched it since - I'm a SQL guy - not much of a network guy... – Mike DeFehr Jul 29 '13 at 14:08
  • It's probably fine, try running ping aklasjdlfjskd on the command line. It should return "host not found" or similar. If it finds an IP to ping, you've got a default record somewhere that's tripping up the cluster. – Chris S Jul 29 '13 at 14:14
  • It returns with the IP address of a server at opendns which is where the external DNS server goes when looking up external addresses - All that is set up on the external DNS server is a forwarder - I need that (I think) in order to resolve external addresses - not sure how to make it work properly, but at least I know where to start looking now - thanks – Mike DeFehr Jul 29 '13 at 14:35
  • Excellent - I added a Forward lookup zone on my external DNS server for my domain - this presumably became authoritative on the domain and it stopped forwarding the requests to OpenDNS - do you want to propose an answer? – Mike DeFehr Jul 29 '13 at 14:54
1

Temporarily disable your external network adapter and ping aklasjdlfjskd. This time the ping should return "Host not found" or a similar error. Repeat the step to add a cluster name and ip address and it should work fine. After this you can re-enable your external network adapter.

  • 1
    Just for the sake of random curiosity, what is this supposed to do? – Falcon Momot Jan 13 '14 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.