3

I'm not that experience with Linux, but I'm trying to install some software on 64-bit CentOS 6.3 that requires the following packages (copying them exactly as written in the documentation stating they're required external dependencies for Red Hat, SUSE, Fedora, and CentOS):

HAL packages: libhal1 
              libhal-storage1
QT library:   libqt4-core
              libqt4-gui

The software explicitly supports 64-bit CentOS 6.3, as well as other other Linux flavors.

Where can I find these packages? I don't see them here:

http://centos.mirror.nexicom.net/6/os/x86_64/Packages/

http://rpm.pbone.net/

I also tried yum info pkgname and yum search pkgname as root user and using various wildcards in pkgname to expand the search, but found nothing.

What do people do in these situations?

Any idea? Thanks in advance.

2
  • What the software? Have you tried install from binary package or from source?
    – ALex_hha
    Jul 29, 2013 at 22:16
  • The software's installation has options for either RPM or command line.
    – gkdsp
    Jul 29, 2013 at 22:34

2 Answers 2

6

If you are installing RPM-packaged software for your distribution, you can just use yum to install it, and it will locate and install the dependencies automatically, provided it was packaged correctly by its maintainer.

yum install /tmp/mypackage-1.2-3.x86_64.rpm

Note that you can't do this with packages from incompatible distributions (e.g. you can't install a SuSE package on CentOS).

6
  • Thanks for that. The software instructions (same instructions apply to Red Hat, SUSE, Fedora, and CentOS) state to run: rpm --import RPM-GPG-KEY-CompanyAuthenticationClient then run: rpm -hi -CompanyAuthenticationClient-1.2.3-0.x86_64.rpm. Is it crazy to expect the same package to work on all Red Hat, SUSE, Fedora, and CentOS using yum to install it? Or, is it a no-brainer I should use yum and forget about installing the external dependencies manually?
    – gkdsp
    Jul 29, 2013 at 23:10
  • 1
    Yes, different distributions package their libraries differently, and thus unless they're 100% binary compatible (e.g. RHEL to CentOS) it's not guaranteed to work. In this case, I think you'd be fine with importing their RPM GPG key, and then using yum install CompanyAuthenticationClient-1.2.3-0.x86_64.rpm. If they have multiple RPMs to install, specify them all on the same yum command line. Give it a go. Jul 29, 2013 at 23:14
  • Note the -hi parameter above is described as: "-hi is the parameter for installation." Should the yum command be yum install -hi CompanyAuthenticationClient-1.2.3-0.x86_64.rpm, or as you have it without the -hi (since yum install is there). Or, does it mean I can't use yum?
    – gkdsp
    Jul 30, 2013 at 1:21
  • 3
    No, you omit it. Those are rpm options. Do it exactly as I gave it. If it was supposed to be there, I would have added it. :) Jul 30, 2013 at 1:26
  • Thanks, I see the rpm command h is used to print hash marks during install and the i is for install. Great!
    – gkdsp
    Jul 30, 2013 at 1:28
7

In general, you can install the software and see what libraries it complains are missing (or run ldd on the binaries) and then use yum whatprovides '*/foo.so'.

In this case, however, looking at the requirements and what RPMs are available for CentOS 6, most likely you need to install hal-libs, hal-storage-addon, qt, and qt-x11.

4
  • Is the benefit of "seeing what libraries are missing" that it will provide more accurate names for me to use to search for? If not, what's the advantage of doing this? (I'd be worried something breaks) Also, how did you arrive at those alternative names (e.g. hal-libs,hal-storage-addon, etc.)? That is, is it pretty common in the Linux world to be instructed to add on packages using some generic name, which really require a different name to install? The names I originally posted above also apply to SUSE and Fedora, so perhaps they're generic names, which is misleading me.
    – gkdsp
    Jul 29, 2013 at 22:40
  • 1
    If I had no idea whaat the packages might be, I would have started with "yum search hal" and "yum search qt" then narrowed down from there. Jul 29, 2013 at 22:52
  • 1
    It will provide exact names of files needed which in turn can be fed to yum whatprovides to get the needed package to install. I arrived at those alternative names by scanning at centos.mirror.nexicom.net/6/os/x86_64/Packages for something with a similar name. Edit: Every distro needs to be a special snowflake and name packages slightly differently. Jul 29, 2013 at 22:53
  • So, it sounds like, in the Linux world, it's not that unusual to be instructed to install a certain package and end up needing to install a package with a (slightly) different name depending on the distribution (e.g. Red Hat, CentOS, etc.), because each distro requires a unique name.
    – gkdsp
    Jul 29, 2013 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.