0

I cannot checkout from my SVN repo with the following configuration on Ubuntu:

svnserve.conf:

[general]
anon-access = none
auth-access = write
password-db = passwd
authz-db = authz
[sasl]

authz content:

[aliases]

[groups]

[/procode]
kompi = rw
tlevi = rw

[/procode/code]
david = rw
test = rw

passwd content:

[users]
david = aaa
adam = aaa
levi = aaa
test = aaa

my repo is located in /home/kompi/business

I start svnserver with: svnserve -d -r /home/kompi/business --log-file /home/kompi/svnservelog.txt

version is: svnserve, version 1.6.12 (r955767)

and contains a procode subdirectory. I try to checkout with tortoiseSVN, with every user, but I always get an Authorization failed error.

0
  1. I think, you can (have?) to define some rules for / path in authz file: $authenticated = r isn't too wide
  2. If /home/kompi/business is repo, you started svnserve wrongly: -r option defines root of repository collection and must be parent folder for all and any repository

PS: It's better to troubleshoot svn-related problems in CLI: svn ls /URL/OF/REPO give you more detailed information

  • adding access to the root helped me debug the real problem, which was that I used the wrong URL for checkout. I used the same URL as I use for SVN+SSH, but with svnserve the URL differs – Kompi Jul 31 '13 at 8:41
0

The real problem was that I used the same checkout URL I used with SVN+SSH

svn+ssh://servername/home/kompi/business/procode

But when you use svnserve, the root of the url becomes your repo, so the correct URL will be:

svn://servername/procode

0

Have you tried to use something else than TortoiseSVN? I had trouble with it, and to make sure the problem was not TortoiseSVN itself I installed RapidSVN, which worked fine with the same url.

There is definitely something new in TortoiseSVN that does not work with our SVN server. I am not sure what, but they did something, because TortoiseSVN has never failed me before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.