Recently I've been attempting to setup a filezilla server on one of azure virtual machines and cannot seem to get it fully running. I am currently able to get an initial connection, however subsequent data connections (i.e. for listing remote directories, file transfers etc..) always fail. I have tried following the advice on various blogs like this one:


however I still get the same results.

Azure manager settings

unfortuantely I don't have enough reputation to post pictures of the configuration, so I will try my best to describe them.

for the server I have 2 Endpoints open for ftp.

  • TCP public port: 21, private port: 21
  • TCP public port: 65100, private port: 65100

General server settings

For the purpose of eliminating potential sources of errors I have temporarily turned off windows firewall on the server, so that should not affect the results that I'm seeing here.

FileZilla PASV settings

  • use custom port range checked. range used was 65100 - 65100
  • use the following IP checked, with the public virtual IP (VIP) Address from the azure dashboard.
  • Don't use external IP for local connections unchecked


Connection Attempt Log

Status: Connecting to XXX.XXX.XXX.XXX...
Status: Connection established, waiting for welcome message...
Response:   220-FileZilla Server version 0.9.41 beta
Response:   220-written by Tim Kosse (Tim.Kosse@gmx.de)
Response:   220 Please visit http://sourceforge.net/projects/filezilla/
Command:    USER x
Response:   331 Password required for x
Command:    PASS ********
Response:   230 Logged on
Status: Connected
Status: Retrieving directory listing...
Command:    PWD
Response:   257 "/" is current directory.
Command:    TYPE I
Response:   200 Type set to I
Command:    PASV
Response:   227 Entering Passive Mode (XXX,XXX,XXX,43,254,76)
Command:    MLSD
Response:   425 Can't open data connection.
Error:  Failed to retrieve directory listing



  • +1 thanks for posting this! I was missing the passive settings to make my vm work. – Eonasdan Sep 17 '13 at 15:20

Managed to finally figure this out after a lot of head scratching. Turns out that azure has implemented a probing of sorts on ports opened using the manager. deleting the passive ports created there and opening them up using powershell allowed this to work.

Here's a good article describing the process: http://social.msdn.microsoft.com/Forums/windowsazure/en-US/8f697f17-72b7-46f7-8c97-398b91190a2f/server-2012-vm-on-azure-passive-ftp-wont-work

  • FYI, we have an update coming soon that will make it easier to manage probes for endpoints. Once it's available, the behavior of default probing will be removed. – Tabrez Mohammed Aug 2 '13 at 16:17
  • I am able to install filezilla in the windows azure and connect inside the server as FTP However I am not able to connect from outside. What could be the issue. I followed the same instruction. – Karthick Mar 14 '14 at 14:20

Goto settings of filezilla.

change the FTP setting.

instead of passive mode -- select active mode and click ok.

try now it will work.

azure doesn't allow passive ftp, thats the head scratching thing here.

  • This is the solution that worked for me! Thank you. I was trying to connect to one of Azure VMs via another one. – Burak F. Kilicaslan Mar 29 '17 at 21:12

Short summary of what can fix this issue. Worked for me.

  1. Azure VM - Firewall

    1.1) Open Inbound port 21

    1.2) Open few Inbound ports for Passive mode - Say 1035 to 1040

  2. Azure VM - FileZilla Server

    2.1) In settings - Change Passive ports to 1035 to 1040 ( or what ever ports you opened in 1.2 above )

    2.2) For "External Server IP" option, use "Retrieve external IP address from"

  3. Azure Control Panel - Endpoints

    3.1) Open port 21, and 1035 to 1040 ( or what ever ports you opened in 1.2 above )

  • Works like charm! For my case, I used port 60000 instead, because it was allowed by default by my Azure Network Group and VM – Ryan Teh Nov 30 '20 at 14:15

Azure now have an FTP VM in the marketplace that fully setups FileZilla FTP Server and configures the required ports to allow external access to your public IP https://azuremarketplace.microsoft.com/en-gb/marketplace/apps/cloud-infrastructure-services.filezilla-ftp-server

Setup instructions: https://cloudinfrastructureservices.co.uk/install-filezilla-secure-ftp-server-on-azure-server-2016/


I decided that I can make it on my own, but got same error as in the queston. But then I googled a little (also saw this question), few hours of trying some manuals, and, finnaly here I found working thing! Hope it helps to other people http://itq.nl/walkthrough-hosting-ftp-on-iis-7-5-a-windows-azure-vm-2/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.