0

This is my first post on here, so I hope i'm posting on the correct site.

I am creating a temporary backup solution for several windows 7 machines that are on our domain. The Win 7 machines will be running the default windows 7 backup, and then a script will run to have those files moved to a file server for storage. Since our users are not allowed local administrative rights to their computers, the Scheduled task that runs the script uses the local administrator account. The problem is that the local administrator does not have access to the share. Is there a work around to give the local admin account permissions to a file share on the domain?

I have tried adding the computer itself to the share. Example, adding testcomputer$ to the share. This bared no results. Any info on this is would be great.

  • Why not configure the task to use a domain account that has access to the share? – joeqwerty Jul 30 '13 at 15:22
  • The account running the script needs permissions to the Backup file. When windows 7 creates a backup file it does not give permission automatically to the domain user on the computer. Only to the system and administrator account. – Sam Pleggenkuhle Jul 30 '13 at 15:30
  • 2
    don't run the schedule task as administrator run run it as "nt system" then the testcomputer$ technique will work. – tony roth Jul 30 '13 at 16:18
  • @tonyroth I'm not fammiliar with the user "nt system". Unless you are referring to the "nt authority\system" in which case I thought that only applies to server 2000,2003 and XP. The task is being run on the windows 7 machine, and that user doesnt seem to be able to run the task. I believe you just are referring to the system account. I will give that a try. – Sam Pleggenkuhle Jul 30 '13 at 17:02
  • @tonyroth Making the task run under the System account and giving the "testcomputer$" permission worked like a charm. In my previous comment I just misunderstood which user you were referring to. Thanks – Sam Pleggenkuhle Jul 30 '13 at 17:27
2

don't run the schedule task as administrator run run it as "nt system" then the testcomputer$ technique will work

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.