3

I am trying to do a PXE boot from a LTSP server connected directly to the client computer.

My problem is, during netboot, it says:

CLIENT MAC ADDR: 8C 89 A5 E0 6C 86 GUID: 000000000-0000-0000-0000-8C89A5E06C86
CLIENT IP: 192.168.1.7 MASK: 255.255.255.0 DHCP IP: 192.168.1.2
GATEWAY IP: 192.168.1.1

PXE-E11: ARP timeout

PXE-E11: ARP timeout 
PXE-E38: TFTP cannot open connection
PXE-M0F: Exiting PXE ROM.

Reboot and select proper Boot device
or Insert Boot Media in selected Boot device and press a key

I don't understand how to solve this issue. I could boot it up properly earlier, and when the server rebooted, I am getting this error.

Please help!

EDIT:

my /etc/ltsp/dhcpd.conf file is as follows:

option domain-name-servers 8.8.8.8 8.8.4.4;
default-lease-time 86500;
max-lease-time 6059934;
authoritative;
option domain-name "BLAX";
allow booting;
allow bootp;
next-server 192.168.1.2;
filename "ltsp/amd64/pxelinux.0;
ddns-update-style none;
subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.3 192.168.1.250;
    option domain-name "fdf.com";
    option domain-name-servers 8.8.8.8;
    option broadcast-address 192.168.1.255;
    option routers 192.168.1.1;
    option subnet-mask 255.255.255.0;
    option root-path "/opt/ltsp/amd64";
    if substring( option vendor-class-identifier, 0, 9 ) = "PXEClient" {
        filename "ltsp/amd64/pxelinux.0;
    } else {
        filename "ltsp/amd64/nbi.img";
    }
}

Network configuration:

/------------\          /-------------\
|            |          |             |
|192.168.1.7 |          |  192.168.1.2|      /------------\
| Client     o----------o   Server    o------o  Router    |
| Machine    |          |  Machine    |      |192.168.1.1 |
|            |          |             |      /------------\
/------------\           /------------/
  • Is your TFTP server up? And is it the same server you specified in your DHCP options? – Michael Hampton Aug 1 '13 at 12:43
  • yes the TFTP server is up - tested it with $tftp localhost and then a get filename which said filename does not exist. So seems to be up @MichaelHampton – user183996 Aug 1 '13 at 12:44
  • "Connected directly to client computer" What does it mean? And also do you see MAC of client in ARP table on the server? – Danila Ladner Aug 1 '13 at 13:15
  • @DanilaLadner it means, I have connected the one lan cable from one PC to another directly, without a switch or hub or router – user183996 Aug 1 '13 at 13:16
  • GATEWAY IP is 192.168.1.1 is that IP of the server? – Danila Ladner Aug 1 '13 at 13:20
4

In dhcpd.conf, make sure the lines "option domain-name-servers" and "next-server" have the correct IP address.

In the /var/lib/tftpboot/linux-install/pxelinux.cfg files, make sure root=nfs:IP:/directory has the correct IP address.

| improve this answer | |
1

I had such problem when forgot to edit DHCP server configs after changing IP addresses for infrastructure (for the DHCP server too). To fix that:

sed -i -e 's/old_IP/new_IP/g' /etc/dhcp/dhcpd.conf
service dhcpd restart

In addition, the PXE server menus should be updated. In my case:

sed -i -e 's/old_IP/new_IP/g' /*/pxe_server/tftproot/*/pxelinux.cfg/*
| improve this answer | |
0

I also had this issue with a PXE-11 ARP timeout on warewulf boot. For anyone else who is dealing with the issue, check your switch if the other posted solutions don't work. My problem was a bad gigabit switch.

| improve this answer | |
0

Try:

 ltsp-chroot -m 
 apt-get install linux-image-amd64/i386
 apt-get install linux-headers-amd64/i386
 ltsp-update-image 
 ltsp-update-kernels
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy