0

I have UFW enabled on my server. However, I find that it is disabled at times, showing a status of "firewall not loaded". I enable it, verify that it is running (shows loaded and gives me a list of my active rules when asking for status verbose), and if I check it a few minutes later, it shows not loaded again.

I thought there might be a flag in the config to unload itself as a safety feature while it is being configured, but couldn't find anything. It seems to disable itself about every 5 minutes.

It is driving me crazy, any ideas? Could another firewall be loaded and cause the conflict? How would I know?

0

Sounds like the process is failing so check the logs.

If you have a standard install then /var/log/ufw.log and also maybe /var/log/syslog

In my experience your theory of another firewall causing a conflict is not plausible.

If the logs don't show anything, or you cannot find a suitable answer to your problem, try using strace on the process.

strace -o output ufw then check the file called output

0

Check your crontab... as yourself or root or any other user. It is good practice to set up a crontab job to disable the firewall is you are setting it up through ssh. That way you are sure that you didn't mess up and lock yourself out. Maybe somebody forgot to disable that job?

crontab -e

But remember to check from all users that have permission to do this.

  • Reverting to the last known-good configuration seems like a much better plan than disabling the firewall. – kasperd Jul 11 '14 at 21:35
  • Thanks for the tip. Although, I'm not giving an advice, I'm answering the question. – mimoralea Jul 11 '14 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.