On my Ubuntu I have installed:

  • trac 1.0
  • SVN 1.6.17
  • trac plugin for subversion

Then I configured my repository. When I set it it requested me to sync my repository and I did. When I did that the versions were visible in Trac:

  • I could see the source up to the latest version in the "Browse source" tab that appeared.
  • When I go to "Admin" -> "Repositories" I see the correct change version

Then I did change in my source and committed the problems started:

  • My change did not appear in the "Timeline"
  • The source under "Browse source" still was on the previous version and did not show my latest changes
  • "Admin" -> "Repositories" also shows the incorrect, old version of the repository

This perplexed me a lot. I thought it might be something with the permissions, but I am running the deafult tracd with my user user. If I use the same user and do:

trac-admin <my-trac-env> repostory resync <my-repo-name>

I get the new version also synched and all the problems listed above are solved. Of course I will not go and do repository rescync after each compile. Please, help me out figuring what the problem in my configuration might be!


I found what my problem was. Actually they were few.

  1. I, of course, should not have expected that the subversion will automatically know about my trac. I needed to add some svn hooks to make the double-link. I did it following this documentation
  2. After that I still did not get it sunning. That was because I was already running my repository on apache instance on my machine, but trac I ran with the default tracd. That way the two processes were run from different users and the hooks did not have write permission in my trac environment. Configuring trac to run on the apache too was not actually that difficult and I did it following these instructions. For me the most difficult part was to realize that mod_wsgi can be installed by simply:

    sudo apt-get install libapache2-mod-wsgi

After I did these two things now I have my commits being reflected in trac

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.